Highlighted
2 Bronze

Power from a VT4800 dock to XPS 13 9300

Jump to solution

I have a new XPS 13 9300 linked by TB3 to a powered VT4800 dock ( a new model). Ethernet, an external USB drive and a powered P2415Q monitor all run well from the connected dock (so far!).

With just the dock connected to the XPS, not the XPS's power adapter, power gradually drains. The dock manual says up to 60w can be provided. 

Is this normal or is there a problem with the dock providing power?

Thanks

John

0 Kudos
1 Solution

Accepted Solutions
Highlighted
6 Indium

Re: Power from a VT4800 dock to XPS 13 9300

Jump to solution

@john eshin  Glad things are looking better!  Sometimes updates are published to support.dell.com before they're pushed through SupportAssist and Dell Update.  In terms of what to install, if you're the type that's willing to read release notes, then that's usually the best way to make a determination, although release notes don't always document everything that's been changed.  I used to be the type to update everything just because, but between the upticks in the number of things in my life that require updates and the seemingly increasing number of updates that sometimes introduce problems without fixing anything that I needed fixed, I'm gaining more sympathy for the "If it ain't broke, don't fix it" philosophy, especially in cases where release notes are available.  I'll install updates that contain security fixes even if things seem to be working fine, and updates that fix things that I think might affect me even if they don't right now, but if the fixes or enhancements sound like they have no relevance at all to what I'm doing, then I might pass.  However, if you do that with a given release of something like a driver or firmware update, then you'll have to make sure you notice when an even newer release of that driver/firmware update is published so you can recheck the release notes.

Or you can just install all the updates that get pushed.  That's certainly the more common approach overall.

As for "plugged in", that just means it was connected to a power source.  It doesn't distinguish between "conventional" wall power source and docking station, nor does it identify the wattage of the power source.  I hope Dell didn't remove that bit of information completely, although since I don't have one of those myself, I can't look for it.  But then again if things seem to be working, then it's not a big deal.  Hopefully things stay fixed!

View solution in original post

0 Kudos
3 Replies
Highlighted
6 Indium

Re: Power from a VT4800 dock to XPS 13 9300

Jump to solution

@john eshin  The XPS 13 models are designed for a 45W power source, at least that's been the case for a while now.  If you check the power adapter that came with your system, what is its output wattage?  If it's still 45W (or even no more than 60W), then power drain while being powered by the dock sounds like either a problem with the dock or an interoperability problem between the dock and that system.  I don't have that specific XPS 13 model, but typically somewhere in the BIOS Setup or in Dell Power Manager if you have the latter installed, you should be able to find somewhere that the system identifies the wattage of the attached power source.  On older XPS 13 models, this was in the Battery Information section of the BIOS, but I think Dell has changed the interface recently.  What wattage does the system detect when only the dock is connected?  And just as a long shot, have you tried connecting the dock to different USB-C/TB3 ports on the system to see if that makes a difference?

0 Kudos
Highlighted
2 Bronze

Re: Power from a VT4800 dock to XPS 13 9300

Jump to solution

Thanks for this reply.

1. It was draining slowly yesterday. This morning I discovered an "urgent" update for the TB3 driver. This was on Dell | My Account | XPS | Drivers and Downloads. It didn't appear on Dell Downloads or Dell Supportassist software for some reason. Installed it. Now with just the dock connected (no XPS power adapter) it's keeping 100% charge over several hours with YouTube music playing. Fixed it appears!

(A side question. A lot of updates, 4 "urgent", were listed. Should they be installed even tho' it's running fine? Yet the other two Dell apps ran not updating anything. Which should I take notice of? I'm new to Dell and need to learn how to maintain. Thanks)

2. The BIOS showed battery management similar to Dell Power Manager. No sign of what charge it was receiving. DPM said "plugged in". Must mean either adapter or dock without specifying which.

0 Kudos
Highlighted
6 Indium

Re: Power from a VT4800 dock to XPS 13 9300

Jump to solution

@john eshin  Glad things are looking better!  Sometimes updates are published to support.dell.com before they're pushed through SupportAssist and Dell Update.  In terms of what to install, if you're the type that's willing to read release notes, then that's usually the best way to make a determination, although release notes don't always document everything that's been changed.  I used to be the type to update everything just because, but between the upticks in the number of things in my life that require updates and the seemingly increasing number of updates that sometimes introduce problems without fixing anything that I needed fixed, I'm gaining more sympathy for the "If it ain't broke, don't fix it" philosophy, especially in cases where release notes are available.  I'll install updates that contain security fixes even if things seem to be working fine, and updates that fix things that I think might affect me even if they don't right now, but if the fixes or enhancements sound like they have no relevance at all to what I'm doing, then I might pass.  However, if you do that with a given release of something like a driver or firmware update, then you'll have to make sure you notice when an even newer release of that driver/firmware update is published so you can recheck the release notes.

Or you can just install all the updates that get pushed.  That's certainly the more common approach overall.

As for "plugged in", that just means it was connected to a power source.  It doesn't distinguish between "conventional" wall power source and docking station, nor does it identify the wattage of the power source.  I hope Dell didn't remove that bit of information completely, although since I don't have one of those myself, I can't look for it.  But then again if things seem to be working, then it's not a big deal.  Hopefully things stay fixed!

View solution in original post

0 Kudos