Last reply by 11-05-2020 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Solution for audio problems XPS 15 9560 - crackling sound and latency (e.g. in Ableton)


I just wanted to chime in on the many threads by XPS users found all over the internet as I've been through the same issues with my XPS 15 9560 concerning much latency and crackling for music production in DAW software like Ableton. I cannot seem to reply to these topics because most of them are flagged as solved with article links that do not work enough for most users. I hope this helps as I absolutely love my XPS by design and in general I was very happy up until I started music production this year.

So after losing many many time to tweaking (been through it all: BIOS tweaking to no avail, endless Latencymon elimination tests with the same notoriously high peaks for acpi.sys, killer network, nvidia) the fix was strange but mind-boggling effective. So just to list this down this might spare more DELL XPS users precious time and frustration and less topics to browse through. Note that just because it worked wonders for me, this doesn't give you and guarantees but probably worth a try with every XPS.


  • Unplug your XPS battery for 1 minute minimum, then replug it in

So the main solution is to open the back of the laptop (many videos on youtube on how to easily open an XPS for battery replacement e.g.) and unplug the battery for at least 1 minute. To my wonder, the laptop worked three times as fast, like new after doing this. I had noticed some slacking after less than a year of utilization but as it came on gradually, I forgot about how fast my XPS used to be when bought freshly. Now I can bring down the crackling latency in Ableton from a very frustrating and unacceptable 40ms with many many presets in Omnisphere 2 hitting over 90% CPU or even crashing, to a crystal clear 14ms. This is sufficient for most amateur musicians like me, for pros I do not know. Omnisphere 2 now loads instantly and even the heaviest presets never taking the CPU over 34%. Or how unplugging the battery and re-plugging it fixes problems this somehow drastically, and I do wonder how come. Note that you still have to disable Realtek audio driver in device manager and install ASIO4ALL. Works flawlessly for me, the exclusive mode doesn't bother me as I can switch flawlessly between other programs like internet/youtube videos and back to Ableton without any problems.

Secondly, my best practice before this fix -in case it would not work or you want to bring down latency to an absolute minimum- was to pinpoint by elimination the drivers causing the terrible crackling and spikes in CPU beforehand. The following brought down my CPU levels in Ableton and latency significantly to 18.5ms, with the battery fix and the following I can obtain 10ms:

Major difference

  • Disable Realtek Audio (the main culprit) in device manager
  • install ASIO4ALL (buffer = 128 + set the hardware buffer)
  • Disable Killer Network in device manager
  • in Task manager set affinity of the Ableton process to all CPU cores except those most affected by latency (cf. Latencymon), in my case this was removing the Ableton process from Core 1 and Core 0

Minor difference

But don't forget do try the battery trick first.

Even if it only helps a few users looking for a solution it might spare them a lot of time and despair as there are many conflicting fixes on the net with always the same optimization suggestions, with many not making any real differences, at least as it was in my case.

Also, I hope DELL takes into account the XPS issues with latency many have ranging from musician, producers, to programmers and pro-gamers, so future models of this high-end laptop will have no more Realtek and Killer Network but better drivers. If not it would be a shame for such great and high-end laptops from a top brand.


Reply (1)
2 Bronze
2 Bronze

The solution for me was to unninstall Dell Support Assist.

I was having random pops and crackling every 15 minutes or so, and with LatenctyMon I was able to find that the root of the problem was dddriver64Dcsa.sys - Dell Data vault Control Device Driver, Dell Inc.

After disabling that in Device Manager the problem was gone, so I unninstalled everything related.

Latest Solutions
Top Contributor