Highlighted
Ovenist
1 Copper

Thunderbolt 3 port on XPS 15 9570 just stopped working

Hi all

I have been using a hdmi to TB3 adapter to drive my second external monitor (the first one is plugged in directly to the hdmi port) and today it seems the thunderbolt port just plain stopped working. I have tried with two different hdmi to TB3 adapters, I have tried a usb to TB3, nothing works anymore when I plug into the laptop's port.

I am going crazy because I can't pin point to anything I have done that would make it stop working other than switching one of my hdmi cables from a hdmi/hdmi to a hdmi/display port (I have since switched back, to no avail).

I have tried updating drivers of the bios and thunderbolt port, I have done a factory reset of windows, nothing works...

Any help appreciated

0 Kudos
4 Replies
ejn63
5 Rhenium

Re: Thunderbolt 3 port on XPS 15 9570 just stopped working

Time to call Dell and have the mainboard replaced under warranty.

 

0 Kudos
Ovenist
1 Copper

Re: Thunderbolt 3 port on XPS 15 9570 just stopped working

I was afraid the only explanation is a mechanical failure... But that's really disappointing given that the laptop is 2 weeks old...

0 Kudos
ejn63
5 Rhenium

Re: Thunderbolt 3 port on XPS 15 9570 just stopped working

The good part is that if the system was purchased from Dell US, you can also return the system for replacement - which is what I'd do in this case.

Having a mainboard replaced on a brand new system is the equivalent of an engine replacement on a new car.  You're better off with the replacement system.

 

0 Kudos
Ovenist
1 Copper

Re: Thunderbolt 3 port on XPS 15 9570 just stopped working

I am afraid it wasn't from Dell US. But this is my work computer so I returned it to our IT guy and he'll fix it or get me a new one I suppose.

Thanks for the help either way!

0 Kudos