XPS

Last reply by 07-27-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
14978

Trying to get XPS 13 9350 to work with Lenovo ThinkPad USB-C Dock Gen2

Hi all, my wife has a work supplied set up of a Lenovo laptop, dock, monitors and peripherals.  She'd like to be able to plug her personal laptop (XPS 13 9350) in when she's not working to take advantage of the set up and dual monitors, but we're unable to get the monitors working.

When we plug it in it recognises all the peripherals and they work fine, but it doesn't see the monitors and they don't see it.  We're going straight from the dock input to the Thunderbolt / USB-C dock, just as she does with her work laptop.

It's perhaps not that surprising as presumably the dock isn't meant to be a universal one, but when I plug my own laptop in (Xiaomi Mi Notebook Pro) the same way, it all works perfectly and I can use the monitors and peripherals just fine.

I've updated all the drivers (graphics, etc) and all Windows updates.  I'm not sure what else to try but we'd be very appreciative of any assistance in getting it working.

Thanks in advance.

Replies (17)
7 Plutonium
12997

@Geta  Actually that dock is meant to be universal at least among systems with USB-C ports that support video output (aka DisplayPort Alt Mode) and as long as you don't expect support for features that require proprietary support, such as using the dock power button to control the attached system.  If you haven't already, use a Lenovo system to update the dock's firmware, which you can get here.  And then since you didn't mention firmware, you may as well update the XPS 13 9350's BIOS, the latest version of which as of this writing can be found here.

If even that fails, I have a feeling that this dock may be triggering whatever issue prevents the XPS 13 9350 from sending video over USB-C even to Dell's own USB-C displays, an issue that is summarized here.  Dell has never been forthcoming about the underlying cause of that problem, so unfortunately there's no way to know, and the XPS 13 9350 is known to WORK when connected via USB-C to at least some other USB-C displays, but given that the issue documented in that KB article shouldn't exist at all (and yet it does), the scope of the issue might be broader than Dell is acknowledging.  Unfortunately in that case there's nothing to be done.  In the case of Dell USB-C displays, the workaround (for people who didn't like the "Just buy a Dell dock" option suggested in the KB....) was to use a USB-C to DP cable to connect to the display, which worked, but it also meant you were only sending video rather than having USB data connectivity and power.  But when dealing with an actual USB-C dock, that workaround isn't possible even if you'd be ok with the limitations.  So I'm hoping that those two firmware updates resolve this for you, because otherwise there may not be a fix here.  Sorry I don't have better news!


12972

Thanks so much for the detailed and helpful reply, @jphughan

I haven't had the time to try it yet, but hopefully I will this evening and I'll post back with the results.

12940

Well, after applying 10(!) updates, including to the BIOSs, it still doesn't work.

I was very hopeful that it might, when I saw how many updates it required. It turns out she was updating with Intel and Windows Updates, but didn't have the Dell assistant installed for the rest.

So, bugger, I guess    It's very disappointing really, particularly if it's functionality that was broken sometime along the way and never fixed or acknowledged. I'll hope they fix it at some point in the future, but otherwise will have to accept that it's a five year old laptop and live with it.  Thanks again for your help.

12922

@Geta  D'oh!  Sorry to hear that.  In that case like I said, I'm wondering if this Lenovo USB-C dock is triggering the same odd "no video output" behavior that Dell's own USB-C displays do.  I wish I had better news or another suggestion, but you might be stuck.


2 Bronze
2 Bronze
12063

the solution is to install Lenovo display manager software on the dell XPS , to allow the system to manage the dual display .
I have a Mixed configuration and it's working for me :
Dell laptop + 2 Dell Monitors + Lenovo dockstation USB-C
and I had the same issue (black screen) until I installed "in my case" the Dell display manager.

12050

@Oumounid Med  There are several Lenovo USB-C docking stations. The one under discussion here does not require any additional software to be installed in order to get video output, as evidenced by the fact that all of my systems work with it without needing any Display Manager software — EXCEPT the XPS 13 9350. The problem is with the 9350. You did not specify which Dell laptop you’re using or which excavated Lenovo USB-C dock you’re using, so your suggestion isn’t all that helpful. I have multiple Dell laptops that work with the exact Lenovo USB-C dock under discussion here, but again the XPS 13 9350 is a problem case even though it shouldn’t be, and even though it works fine with Lenovo’s TB3 Dock Gen 2 without any display manager software. This is a narrow interoperability issue.


12090

Similar compatibility issue here. I've got a Lenovo USB-C travel hub 4X90M60789 and am trying to connect it to a Latitude 7370, which I believe is a cousin to XPS 13 of the 2016-17 era. Win 10 makes the typical chime upon connecting, a few seconds later another chime sounds but nothing happens. Device manager shows some warning icon next to the USB device and the message "port reset failed." Tried to download a driver for the hub from Lenovo, didn't help. Any advice would be appreciated.

10528

Are you connecting via DP or HDMI?  If DP, there is some bug where the monitor failed to detect a new input signal as it caches information on the monitor.  I had to "hard reset" the monitor ( if there is no power switch ( not the soft power switch in the front panel) by unplugging the power cord on the monitor.

8257

Hi, I was wondering if you can use the power button on the dock?  My XPS works fine with the displays, nice dual 24" and the laptop all showing different pictures.  However, I cannot turn on or off the laptop using the power button on the dock.

Latest Solutions
Top Contributor