XPS

2 Bronze

Trying to update BIOS with a dead battery (insydeflash)

I'm trying to update my BIOS but my battery is dead.  Insydeflash won't let the upgrade progress without 10% charge.  

I found https://www.dell.com/community/Laptops-General-Read-Only/How-to-update-BIOS-on-Dell-Inspiron-3721-wi... but on my XPS it doesn't seam to be following the instructions exactly.  Upon extracting there are no .ini files but after running platform.ini and platforms.ini are both created.  I edited both to skip the battery check and use 0 for the charge level but after re-running, platforms.ini get reset back to defaults.  platform.ini keeps my changes.  Insydeflash still does not skip the battery check.  

Anyone have any ideas what might work?  

Replies (4)
6 Indium

One idea, don't do it. Flashing the BIOS with a dead battery is asking for problems. If for some reason the system loses power during the update, your system is bricked and only a new motherboard can fix it. Even with a good battery unless you are having a specific problem that the update addresses it is better to leave well enough alone. There are numerous posts in the forums from users that have had problems with a BIOS update. If your system is running well than forget the BIOS update.




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B-450M Pro-VDH Max budget build with an Athlon 3000G
Real work on a Latitude E5430
2 Bronze

john855,

I was having the same issue. Here is what worked for me:

1. Delete the files you copied over from the temp folder. 

2. do the steps to create the temp folder again, but before copying them go to View settings in File Explorer and turn on "show hidden files"

3. copy all the files from the temp folder to another location again.

***NOTE: mine did not contain a platform.ini, only a platforms.ini

4. copy the platforms.ini and rename the copied one to platform.ini (no "s") but keep the "s" one as well.

5. open up platform.ini and change the batterycheck to 0 (DO NOT DO IN THE platforms.ini file)

6. run the insydeflash.exe as administrator

Let me know if that works. For some reason editing the platforms.ini will break it every time.

Good Luck!

Thanks Grungecow, this worked!! Brought me to the end of a real headache of an afternoon trying to fix my Inspirion 15-3531.

The battery (a Dell original) was being detected as a dead third-party fake, so I coudn't update the BIOS (which I thought was the problem, having read others with this same issue elsewhere). Paradoxically, the Dell update utility wouldn't run due to the lack of charged battery, and platforms.ini kept correcting itself upon launch (and wouldn't launch at all if the file was put in read-only), so I tried to run it from a USB boot (in itself another headache, apparently there was no Win10 installation media eligible for download with this OEM laptop), but it told me the BIOS update was "not compatible with this version of Windows"

I was about to abandon all hope when luckily I stumbled onto this thread. If anyone finds this, it works! Alas, it appears my battery really is dead (or at least, updating to 3531 A03 didn't fix the system not detecting it properly, if it's not the battery itself, we'll see when I get a replacement).

Also, the American date system is so darn counterintuitive. Really wish they'd switch to something more logical like the British (D-M-Y) or Chinese (Y-M-D). I Initially thought you'd come from the future to give me a solution!

Hi, I tried this as you mentioned. Created the new "platform" and kept the old "platforms". After I tried to run the "H2OFTT-Wx64" I got a "ROM not found" error. Any assistance?

Top Contributor
Latest Solutions