Highlighted
F.Daniel
1 Nickel

[W-LAN] 9360 - Ubuntu LTS 16.04.4 - Qualcom Atheros QCA6174

Guten Tag liebe XPS Community!

TL;DR: Qualcom Atheros W-Lan verweigert Verbindung mit 5 GHz W-Lan Netzwerk auf Ubuntu 16.04.4 LTS. Geschwindigkeit weit unter theoretisch verfügbarer. Ubuntu Treiber Nach-Installation umständlich. Bitte um Hilfe/Ratschläge für Verbesserung der Treiber <-> Ubuntu Kommunikation. Kundenservice verweist auf Community Forum.

Mit wem rede ich?

Meine PCs/Notebooks sind mein Hobby. Ich würde mich als technisch versiert bezeichnen. Mit Linux bin ich erst vor 1 Jahr in Berührung gekommen, beherrsche also nur leicht erweiterte Kenntnisse. Ich habe keine Scheu vor schwarzen Bildschirmen mit weißer Schrift; Fühle mich bei vielen Sachen sogar im Terminal wohler als point&klick… Nur bei Nano/VIM hört die Freundschaft sehr schnell auf.

Die Storry

Sowohl zu Hause als auch an der Universität erlaubt mir die technische Ausstattung vor Ort uneingeschränkte Bewegung in den 5 GHz und 2.4 GHz W-Lan Frequenzen. Den XPS 13 habe ich – ausgestattet mit Ubuntu 16.04.4 LTS – vorwiegend für Programmieren in Python und Fortran gekauft. Natürlich ist so ein leichtes Ultrabook auch praktisch für Filme auf der Couch.

Das Problem

Für die Netzwerkkarte habe ich beim XPS bewusst die „teure“ genommen, um eine stabile Verbindung zu gewährleisten. Eben diese Netzwerkkarte, eine Qualcom Atheros QCA6174 802.11ac verweigert strickt ebenso die Verbindung mit dem 5 GHz Band des W-Lan’s wie auch eine realistische Geschwindigkeit im 2.4 GHz Band. Nach gefühlt 500 Stunden (realistisch 5 Stunden) Suche im Internet habe ich herausgefunden, dass sich die Atheros Module mit diesem Problem auf Ubuntu schon länger den Hass der Community zugezogen haben. Workarounds in „geek“-Foren beschreiben die Installation eines von Qualcom bereitgestellten Treibers. Dieser Treiber wird von meinem XPS entweder nicht akzeptiert oder priorisiert oder gefunden. Jedenfalls funktioniert die Lösung nicht.

Ich bitte dringend um Hilfe/Anweisung wie ich meinem Ubuntu erkläre, eben genau diesen Treiber zu verwenden oder alternative Treiber/Vorschläge/Workarounds.

Datenbeispiele

Bereits nach einer Betonwand vom Sender entfernt fällt die Geschwindigkeit des Moduls auf etwa 1 MB/s ab. Wie eingangs erwähnt behaupte ich mich mit Technik auszukennen. Dazu zählt auch Netzwerkinfrastruktur. Und mit eben diesem Wissen behaupte ich, folgende Werte können so nicht sein! Sogar mit meinem Smartphone (Huawei P9) erreiche ich höhere Werte. Hier ein paar Auszüge:

Unser ISP stellt eine maximale Geschwindigkeit von 120 Mbit/s (15 MB/s) zur Verfügung. Das kommt auch an. [Ein bekannter Online Streamingdienst Anbieter] gibt 10-12 Mbit/s (1.4 - 1.5 MB/s) für HD Videos an.

Mein XPS stottert bei etwas unter 1 MB/s Videos zusammen. Beim Herunterladen von Daten von den Universitätsservern kommt der XPS auf nicht ganz 1.5 MB/s von 15 möglichen. Und ja, die 15 kommen über den Desktop auch an. Stelle ich mich nun neben unsere Router, bekomme ich plötzlich 15 MB/s. aber schon alleine 5 m entfernt freie Sicht Luftlinie sind es nur noch 5 MB/s.

1 ANTWORT 1
Community Manager
Community Manager

Betreff: [W-LAN] 9360 - Ubuntu LTS 16.04.4 - Qualcom Atheros QCA6174

Hi,

Ich sehe du hast ein Ticket zu dem Thema beim Support eröffnet, deswegen solltest du mit Adam Scheffer auch weiterhin in Kontakt bleiben.

 

Unter folgendem Link findest du alle Informationen zum Support(in Englisch) von Linux:

http://www.dell.com/support/article/de/de/debsdt1/SLN290665/EN#Additional

Als zusätzlichen Tipp von mir könnte dir ggf dieser Artikel vom WLAN Modul Hersteller helfen.

https://www.killernetworking.com/driver-downloads/kb/faq/1-killer-1535-1525-1435-in-ubuntu-debian

 

LG Martin

 

PN´s bitte nur auf Anfrage


DellMartin Schiemenz
Community Technologist - Business Client
Social Media and Communities Professional
Twitter | LinkedIn | XINGSupport kontaktieren