hardware408
1 Copper

When XPS15 display enters power save mode, audio out through USB device is interrupted momentarily

Hello,

I have a XPS 15 and found that when the screen times out and enters power save mode (turns display off after the set time), the audio coming from my USB sound device is interrupted briefly.  It comes back on, but this is somewhat annoying when I'm playing back audio projects.  

I tried the same test using the laptop internal speakers, and they are NOT interrupted when the display times out.  

Also, the led light on the USB audio interface did not flicker, so it appeared to not actually lose power.  

Unfortunately I am not sure what to investigate now, and the power saving settings in control panel don't mention external usb devices.  I'd rather not set the screen to be on eternally without power save mode.

Has anybody here ever noticed this? Maybe this is a windows 10 thing and not a Dell thing (I'm new to both), but I thought I would start here.

thanks for any thoughts!

Labels (4)
0 Kudos
2 Replies
Community Manager
Community Manager

Re: When XPS15 display enters power save mode, audio out through USB device is interrupted momentari

Hi hardware408,

Thanks for posting.  Apologies that your system is not performing as expected.

While I believe this is a Windows issue and not a hardware issue, I've researched this and found some information from Microsoft that may be helpful:

How to disable Windows 10's 'USB selective suspend' setting

Please try that and if it's not helping, then post back.  Thanks.


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
Highlighted
hardware408
1 Copper

Re: When XPS15 display enters power save mode, audio out through USB device is interrupted momentari

Following up,

I followed the recommendation to go into the advanced power settings for usb devices and made the changes there.

I haven't noticed that funny audio thing happen since, it seems to have helped.  At least I know those settings are there now, being new to win10 it was not obvious how to get there.  

Very thankful for your help! 

0 Kudos