jeera
1 Copper

XPS 12 (9Q33) A08 to A09 BIOS update failed, laptop bricked

Today I got a popup notification from the Dell Support Center program that an urgent BIOS update was available and wanted to update me from A08 to A09 (presumably to fix the Meltdown/Spectre **bleep**). I let it go ahead and update but it froze during either the writing/verification phase with fans full on. I let it sit for an hour before unplugging the AC adapter and letting the battery run out. After that, the laptop refused to turn on.

A couple hours of googling around found that this is not an uncommon issue with Dell laptops. This blog post detailed a recovery process that worked for different models: https://blog.jmwhite.co.uk/2015/08/09/dell-xps-9530-uefi-bios-recovery/.

I downloaded both A08 and A09 BIOS update files, extracted the .hdr and .rom files, used the Phoenix SLIC tool to obtain the recovery filenames from said .hdr and .rom files, renamed them as directed, and put them on a FAT32 USB drive. I plugged in the USB drive, held down the End key and plugged the AC adapter in. The laptop did turn on at this point and was reading the USB drive but nothing happened from here. More googling around found that other people had this same issue and I failed to find if it's due to the files not being renamed correctly.

So three questions:

1. Has anyone successfully recovered a corrupted BIOS using the above method? If so, what filenames did you use? Mine were CS_A08.hdr, CS_A08.rom, CS_A09.hdr, CS_A09.rom.

 

2. I found an ebay seller with pre-flashed XPS12 BIOS chips for sale. The price is reasonable at $24 but I'd have to pay someone to solder as it's way too small for my skill level. Before I do that, any input on chances this would actually fix things or would the entire mainboard need to be replaced? I'm guessing the mainboard is ok since the thing does power on to some extent when I hold down the End key and plug it in.

 

3. Where exactly is the BIOS chip located on the mainboard? From what I gathered, it's an 8 pin chip and I only see one with markings '4407A' and 'GA3Y24'

 

Thanks!

0 Kudos
2 Replies
tathuy
1 Copper

Re: XPS 12 (9Q33) A08 to A09 BIOS update failed, laptop bric

@jeera: How is your laptop now?

I had the notification today, and I followed all the instructions, and my laptop XPS 12 (9Q33) ended up in the same situation as you described above. It's dead now after struggling at 46% programming EC. I also try the suggestions found on Dell Community without any of them working? 

0 Kudos

Re: XPS 12 (9Q33) A08 to A09 BIOS update failed, laptop bric

I have the same model (DELL XPS 12 9Q33, Core i7) and similar problem (trying to update BIOS from A08 to A09, launching the updater 9Q33_A09.exe and the system totally hangs after a few seconds of allowing it to make chenges to Windows 10), and this solution didn't work: first I tried launching 9Q33_A09.exe with USB HDD plugged in, then with no USB devices plugged in (several times), then with USB mouse plugged in before launching 9Q33_A09.exe and after launching 9Q33_A09.exe. The result is always the same: the laptop totally hangs, only the cooler fan spins. The windows clock in the system tray doesn't advance, and if I plug in the external mouse after the laptop hangs, the mouse doesn't get recognized and activated -- the laser light doesn't turn on.

However, unlike in other cases in this thread, no flashing progress was shown on screen, the laptop just hanged immediately, and I was able to turn it off every time by holding down the manual power off slider.

DELL, can you please help with this? You recommended this update, and I understand that it's required as it deals with Intel Meltdown etc problems. How can I update my BIOS?

0 Kudos