FarmerG
1 Copper

XPS 12 - No bootable devices.

I’m aware this has been already asked loads of times, but nothing’s working from the solutions I’ve seen.

When I turn on the laptop this meeage appears: ‘No bootable devices - strike f1 to reboot, f2 for setup utility. Press f5 to run on board diagnostics.’

I ran diagnostics and the it says no hard drive is found. Everything else is fine. I’ve tried all boot combinations in f2 but it just ends up with the same message.

So it’s the hard drive. I open it up, reseat it, screw everything back up again. It works, for about a day to a week, then I need to do it again.

Sometimes I get it working without opening it up, most of the time not. When I do get it working, it runs slow and says my hard drive is very full, though there’s not that much on it. I’ve cleaned up files and defragged, got rid of malware etc but it always creeps back up nearly full.

So I checked if my OS (windows 10) is corrupt. Haven’t been able to do updates lately because of the hard drive being so full. So I reinstalled it and managed to clear enough room to get it all up to date. It booted successfully for just over a fortnight, then resumed not working again.

I’ve had to reseat every day, then every time I turned it on. It sometimes booted with the screen turned upside round (as if you’d rotated it while using as a tablet) freezes and the ‘something went wrong’ blue screen appears. Now it won’t even do that. It’s sending me round the bend.

I’ve servued the hard drive as much as I can, it’s **bleep** down, it can’t move.

Is their anything else I can try myself to get it back up and running? Is the hard drive fried? Should I just recover the data?

I’d like to know what the issue is before I get the pros in. I don’t have warranty. Thanks.

0 Kudos
2 Replies
ejn63
5 Rhenium

Re: XPS 12 - No bootable devices.

If the SSD isn't recognized, there's not much you're going to be able to do short of replacing the drive - what you need depends on which XPS 12 you have (9250, 9Q23, 9Q33).  

Recovering data from a solid state drive that the system doesn't recognize will require a data recovery service - and recovering data from any SSD is time consuming and far from a sure thing.  Unless you find the data irreplaceable - and worth well over the $1,000 recovery is likely to cost -- this is likely to end up as a data write-off.

 

0 Kudos

Re: XPS 12 - No bootable devices.

I have been having a somewhat similar problem: most times when I turn the laptop on the keyboard lights up and the fan starts spinning but the screen stays black. I wait and turn it off manually by holding down the power off switch for 10 seconds. Then I do it again and again 10 or 20 or 50 times, and one of these times the screen comes alive and it starts booting. Once Windows boots then it works fine for anywhere between a day and a few days (I never turn it off), and then if I turn it off or if it turns off on its own (even though the power settings are set to never power down and never sleep when on AC power), the story repeats.

OCCASIONALLY during my attempts to start it I get to see the message you described (F1 to reboot, F2 to enter bios, F5 to run PSA), but not very often.

I ran the PSA today -- all hardware tests passed fine.

My system board was replaced less than a year ago, and that's when (after a while) all these problems started.

Can someone from DELL comment on this, please?

 

0 Kudos