yorkbeary
1 Copper

XPS 13 7390 2-in-1 can't sleep properly

When I put the XPS13 into sleep (eg. by closing the lid, pressing the power button etc.), the LCD is properly turned off, but the CPU still remains quite active (with the fan still rotating, gradually slower over several minutes, but even after several hours, the fan is still rotating slowly),  Battery drains considerably during this “sleep” mode (approx. 20% drain overnight). The system can be "woken up" instantly by any key stroke or mouse click. From my experience, this behaviors resembles a S1 sleep of a desktop computer (which is shallower compared to S3 sleep, which powers off most peripherals and all fans)

I’ve tried to restore Windows power settings to default, and disabling Wifi / Touch panel / USB and even SD Card in BIOS but no use. All driver updated to the newest version.

7 Replies
cattaka
1 Copper

Re: XPS 13 7390 2-in-1 can't sleep properly

I have same issue. Even its LCD turned off, the fan is still working.

0 Kudos
cattaka
1 Copper

Re: XPS 13 7390 2-in-1 can't sleep properly

It seems that XPS 9570 had same problem and it was fixed.

https://www.dell.com/community/XPS/XPS-9570-BIOS-Sleep-Mode-Gone/td-p/6131926/page/11

But XPS 7390 has still broken.

0 Kudos
samos1111
3 Cadmium

Re: XPS 13 7390 2-in-1 can't sleep properly

It seems that XPS 9570 had same problem and it was fixed. 

 

It was not fixed.

Modern Sleep S0 is broken by design by Microsoft. It isn't bag-safe, and drains battery faster than the old S3 sleep. One can try debugging acute sleep problems with SleepStudy, but they may be difficult to fix if originating in the OS or the necessary drivers. One can't make the laptop really sleep in S3 - it keeps checking for any "important" tasks an may decide to work at its own will. It is possible to turn off wifi during sleep, but this may not help. 

Dell could provide a BIOS option for reverting to S3 sleep properly. Without it, hacks are possible, but don't seem to work reliably for all (try replicating the success reports). Besides, there were certain S3 sleep bugs in XPS laptops that have never been fixed. 

0 Kudos
Puten
1 Copper

Re: XPS 13 7390 2-in-1 can't sleep properly

I have the similar issue, I ran a simple task that wrote a line to a text file and it worked even in "sleep" mode

the most annoying that the fans continue working. I hope DELL will fix that with a bios update.

0 Kudos
DELL-Cares
Moderator
Moderator

Re: XPS 13 7390 2-in-1 can't sleep properly

Workaround for Modern Standby battery consumption and heat
* Highlight on the battery icon (bottom right)
* Right click and click Power Options
* On the left side navigation, click "Choose what the power buttons do"
* On, "When I press the power button", change On battery and Plugged in to "Shut down"
* Click Save changes

 

Modern Standby, the Battery drains quicker

 

 


Social Media Support

#IWork4Dell
To help us troubleshoot, click our Dell-Cares name and send us a private message with your Dell PC or Monitor Service Tag number

0 Kudos
theslug
2 Bronze

Re: XPS 13 7390 2-in-1 can't sleep properly

Hate to say it, but I spent two years with an XPS 13 that had the same modern standby issue. 😞

minsam
3 Argentum

Re: XPS 13 7390 2-in-1 can't sleep properly

This has not been closed, it is recommended to reinstall the system first, not yet, it may be the motherboard problem
0 Kudos