XPS

2 Bronze

XPS 13 7390 2-in-1 problem with adapters

Hi,

I just received the XPS 13 7390 2-in-1 laptop, but I am having some problems with my display adapters.

I was using two USB-c adapters to connect two screens in my previous laptop (not Dell), and they worked perfectly. The first one is just a USB-c to HDMI adapter; the second one is a USB-c Cable Matters multiport adapter that has an HDMI, ethernet, two USB 3.0 and power delivery up to 60W.

The problem is that the adapters work when they want, the first one I have to plug it in and out several times until it works. The second one I can make all the port to work, but at the moment that I want to charge the laptop and I connect the original dell charger to the multiport, everything stops working (and of course, the laptop doesn't charge).

I really don't know what is the issue, I already checked that every driver and Windows is updated, run hardware test, etc. What is curious is that the USB-c to USB-A 3.0 adapter that came with the computer works perfectly in both ports, and of course, the charger works on both as well.

This is the first adapter:

USB C to HDMI Adapter (4K@60Hz), CHOETECH USB 3.1 Type C (Thunderbolt 3 Compatible) to HDMI Adapter
 
This is the second adapter:
 

I hope that someone can help me.

Thanks!

 

Replies (7)
Moderator
Moderator

@Giovai thanks for getting in touch. 

Ultimately, we can't guarantee functionality and compatibility of 3rd party adaptors. You have mentioned that the Dell USB-C that shipped with the system works fine on the system which confirms the Dell hardware is working correctly. Updating the BIOS and drivers would be my next suggestion however you have already tried that.

As they worked perfectly on your other system it confirms that that they are also technically functional. 

Unless you have another 7390 to test them with, I would say we can't guarantee their compatibility.

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

2 Bronze

I suggest you try this dock: https://www.amazon.ca/dp/B07RZ8SNKK/ref=cm_sw_em_r_mt_dp_U_0kjPDbBZPZFMW

It's working well for me with one 4k 60hz monitor with my 7390 2-in-1. Note if you use two 4K monitors with it, they are limited to 4k 30Hz

Thanks!

I am going to try, if it doesn't work I will have a clue that something may be wrong with my unit.

You don't have any problems to connect it? (that it doesn't work every time you connect it)

You had to make any configuration?

It's been mostly fine, I have had occasions where I boot up with it connected and it's not recognised, in these cases I switch to the other port and it works fine again.

The dell 45W power adapter works fine with the passthrough power port to the laptop, no complaints of "low power" that I've had with a couple other adapters I tried. Note I'm in the UK, so using a UK power adapter, but I assume they're producing the same power in Canada.

I use one of the USB2 ports for a USB headset which works well, I haven't tried the ethernet as I don't have a need.

Looks like I have the same problem, where the PD is not charging my laptop when connected to a QGeem 4 in 1 adapter. It worked for me couple of times, after doing some switching around the ports and/or restarting the XPS 13 2 in 1. Its not reliably charging my laptop everytime i use the adapter.

I got some BIOS updates over the weekend. Even after that, it does not work when using the 4 in 1 adapter.

 

@Dell_Manvi can you advise whether the system charges correctly every time you connect the Dell ac adaptor that shipped with the system?

If the system is recognising and charging correctly with the Dell shipped adaptor then we know the hardware is working fine. 

Ultimately we can't guarantee the compatibility and functionality of third party products.

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

7 Thorium

I'm not sure what's going on either, but fyi if you're only using the original Dell charger through that multi-port adapter, be aware that multi-port adapters like that will switch from drawing power from the system over to drawing power from the power adapter, and some multi-port adapters will support providing more power on their USB-A ports when they're connected directly to external power.  The result is that the laptop will no longer get the full wattage capacity of the original power source.  I realize in your case at the moment it's not working at all, but I thought you might want to know this.  The XPS 13 models are designed for a 45W power source, so if you had a 60W USB-C wall charger available, chances are that (with things working correctly) you could use that with the multi-port adapter and still get 45W to the laptop -- but if you're only using the 45W adapter that came with the laptop itself as your power source, your laptop won't have as much power as it's supposed to.  The effects of that can include slower battery charging and in some cases throttled performance.

In terms of the issue itself, if you've already updated your drivers, also update your BIOS if you haven't already.  If you have, then the 7390 is still relatively new, so it's possible that there are some still unresolved bugs in drivers/firmware that could be causing this, in which case your only option might be to wait.  Everything you're using is supposed to be plug and play, so other than making sure everything is updated, there isn't much else to do at this point.  Sorry!


Top Contributor
Latest Solutions