1 Copper

XPS 13 7390 Clamshell won't start


I received my brand new XPS 13 2 days ago and this morning it will not start at all.

Nothing is connected to the XPS.

I closed and reopen the lid dozens of times, I pressed the on button several times for over 30 seconds. I tried it with the power cord connected and disconnected.

Nothing happens, just the white LED light on the front of the PC that will light up 2 seconds once I have plugged in the charger.

I switched it off, last night around 70% charged, I fully stopped it with the windows menu (not suspend mode) then I plugged the charger.

I need it for work and this is putting me in a super stressful mode as it is my only laptop, I bought it to replace the previous one that died.

This model will not allow battery access to disconnect. I tried the online recommendation of RTC reset, with zero results.

Help would be very welcomed.

0 Kudos
3 Replies
5 Rhenium

Re: XPS 13 7390 Clamshell won't start

Actually following the instructions on the support page here, the battery is accessible on the 2 in 1 which I assume you have. Once you disconnect the battery (you don't have to remove it just disconnect) and unplug the adapter, press and hold down the power button for 30 seconds. Then reconnect everything and try again. When you remove the cover just follow the directions and do it carefully. And this video is for the 9360 but the cover removes very much like the 7390.

-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built ASUS B450-F Gaming with Ryzen 5 2600X
Real work on an Inspiron 15 5575 and Latitude E5430
0 Kudos
1 Copper

Re: XPS 13 7390 Clamshell won't start

Thanks a lot for your help.

I was about to get it sent back as nothing worked until it finally restarted after my holding of the on/off button for a few minutes... weird.

on boot up I updated to the latest bios and stopped the PC, then it restarted normally. 

Problem solved. Thanks again for the kind help.


0 Kudos

Re: XPS 13 7390 Clamshell won't start

Great! I am glad to hear that.



Social Media Support
0 Kudos