Last reply by 09-25-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 7930 external monitor not connecting


I recently bought an LG 32un880-b monitor.

When I connect my dell laptop to it with the provided usb-c cable the laptop charges but it cannot find the monitor.
I tried all the ports of my laptop and the cable is usb-c to usb-c without any hubs in between and also while charging the laptop with the power adapter.

It also gives a pop-up saying: "Display connection migth be limited, make sure the DisplayPort device you're connecting to is supported by your PC"

I have all drivers and Windows 10 up to date.
It has the Intel UHD Graphics processor.

I tried using the detect screen function of Windows and of Intel Graphics Command Center but they cannot detect anything.

My laptop has 

  • Two USB Thunderbolt 3 (Type-C) ports with Power Delivery
  • One USB 3.1 Gen 2 (Type-C) port with Power Delivery/DisplayPort

The monitor has

  • USB-C with DP Alternate Mode, max. 3840 x 2160 @60hz, data transmission and 60W power.

I'm running out of ideas to try and I have no idea why it is not working.

Also, I have a HP laptop with a similar Thunderbolt 3 (Type-C) ports with Power Delivery and this one works with the same monitor and cable, so I think the problem is my dell laptop.

Thanks for helping!

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze

I went to the store and had the monitor replaced by a new one and now everything works as it should.

So it was the monitor after all.

Thanks to all for helping me and especially @jphughan for helping me understand it all a bit better!

View solution in original post

Replies (19)
3 Zinc

I know you said W10 and drivers are up to date. Did you check for updates through SupportAssist? Also have you ran any diagnostics in SupportAssist or BIOS?

7 Thorium

This forum thread may help. Especially the comments by @jphughan  who has expertise with that problem and is very knowledgeable. 

-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with GIGABYTE B560M DS3H AC budget build with an i3 10100
Real work on a Latitude E5430

In the support assist everything is up to date and there are no issues in the diagnostics.
In the bios everything is also up to date and also no issues with the diagnostics.

I have not tried to update the firmware of the monitor yet, so I'm trying this now.


Thanks for the reply, I read the thread you linked.
Here the recommondation is the use a USB-C to USB-C cable, and that is what I am already doing.

They have a second recommondation in case that is not an option (which it is on my setup) and that is to use a USB-C to Displayport cable.
I presume this would work, but I would loose the power supply and upstream function with this.


The firmware of the monitor is updated now, and I retried all the ports and turning everything off and on again but still no luck.

7 Plutonium

@sj86  Can you confirm the system you’re using? There’s no XPS 13 7930. There’s a 9370 and a 7390 though, and there are both regular clamshell and 2-in-1 variants of the latter. This can potentially matter given that you’re dealing with an 4K display, because of those three systems, only the 7390 2-in-1 would be able to run 4K 60 Hz and USB 3.x over a single USB-C cable simultaneously. The others would be limited to either 4K 30 Hz + USB 3.x or 4K 60 Hz + USB 2.0. Just fyi in case that’s important to you.

That said, all of those systems should support video output over a USB-C to USB-C cable out of all of their ports, so if you’ve already confirmed that the cable works properly with another system, and you’ve updated drivers and firmware on the XPS 13 side, and you’ve updated firmware on the display side, then you may have stumbled on one of the tech world’s many annoying cases of interoperability issues that shouldn’t exist but do nonetheless. The first XPS 13 to include USB-C, namely the 9350, has an interop problem that renders it unable to output video over a USB-C to USB-C cable when connected to Dell’s own USB-C displays, even though it works fine with multiple other display brands, and USB-C to DP works fine, and Dell USB-C displays work fine with other systems.

In terms of a workaround, if you want to keep the display, there are USB-C to DP cables and dongles that incorporate a USB-C power input, like this one


@sj86  Apologies, my original post contained a link to the wrong product. I have just edited it to fix that.


It is indeed the XPS 13 7390, the regular clamshell, not the 2-in-1.
I have updated everything on both the laptop and the monitor.

Thanks for the info about the limitations and for the link about the dongle.
This dongle would also allow for the monitor to be used as an upstream hub?

I found some other issues online from people having connection issues with the monitor one other devices, so I'm going to send the monitor back to the shop under warranty and have them have a look at it.

7 Plutonium

@sj86  Happy to help. No, a USB-C to DP adapter would only handle video, and possibly power with the right sort of adapter. It would not carry any USB data signal, so that cable would not allow the display to be used as a downstream hub (not upstream, since upstream means closer to or toward the host system, and downstream means farther from or away from it).  If the display included any secondary upstream USB ports that could create a USB data path between the display and host system over a separate cable, then you'd be fine by simply adding another cable, and some Dell USB-C displays include this secondary data-only upstream USB port for this exact reason, but it doesn't look like the LG display has that.

I also just noticed that this display is actually a 4K HDR display. The regular XPS 13 7390 only supports DisplayPort 1.2 over its USB-C ports, which doesn't have any formal support for HDR standards (that didn't arrive until DP 1.4) and doesn't have the bandwidth capacity to do 4K 60 Hz and HDR all at the same time anyway. So if that's a dealbreaker for you, then you may want to either look at other displays that will allow you to save cash by not spending money on features you can't use, or else getting a different system. And actually I'm not sure if even DP 1.4 can run 4K 60 Hz with HDR plus USB 3.x simultaneously. It can definitely do 4K 60 Hz HDR on its own, and 4K 60 Hz SDR with USB 3.x, but I'm not sure about HDR.

Sorry I don't have better news for you!

Latest Solutions
Top Contributor