XPS

Last reply by 03-08-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
4467

XPS 13 9300 (2020) drops ethernet

Have tried two different USB-C hubs (Belkin and HooToo, links below) but ethernet (and internet) keeps dropping every half-hour to an hour.  The network/internet icon on task bar would show "Not Connected" all of a sudden, even though the ethernet RJ45 jack LED light on the USB-C hub still flashes green (normal and connected).  It's very troublesome especially during Zoom meetings! 
 
Unplugging the USB-C hub and re-plugging it in would bring the ethernet back but the frequent needs to re-connect is unbearable. 
 
Unfortunately this is the part of the home office without WiFi signal so need to use physical cable.
 
Does anyone have same experience / have solution?
 
I actually have two XPS 13 (2020) at home and connection is stable for the other one (using Belkin USB-C hub)
 
Appreciate your help on this.
 
USB-C hubs:
 
 
 
 

 

Replies (19)
609

Scratch that, still getting drops. Read this "fix" on another thread and haven't had any disconnects for 4 days:

Go into BIOS>Pre-boot> Disable MAC Address Pass-Through.

Seems to cause a conflict when enabled.

2 Bronze
2 Bronze
626

What seems to have worked for me is:

Disable Energy-Efficient Ethernet AND Wake on magic packet

My driver version is 10.48.914.2021.

2 Bronze
2 Bronze
686

see my original post here https://www.dell.com/community/XPS/XPS-13-9310-2020-drops-ethernet/td-p/7756073/page/2

Guess I have a solution!

I had some long-lasting video conferences today and have some really good news...no disconnect issues anymore! Looks like this driver  https://www.realtektreiber.de/en/realtek-usb-fe-gbe-ethernet-controller-driver-download-update/ fixed the problem completely!

To be precise: 

Realtek USB GBE Ethernet Controller Driver for Windows, update time 2021/06/25

Furthermore, these are my setting for my Realtek USB GBE Family Ethernet Controller which do not solve the problem itself:

adaptive link speed -> disabled

energy efficient ethernet -. disabled

green ethernet -> disabled

speed & duplex -> auto negotiation

 

Already informed Dell

2 Bronze
2 Bronze
760

I'm having the exact same issue. Changing the adapter settings didn't work for me either.
I now have my network connected over an additional hub and it seems to work fine...

Laptop --> HP USB-C docking --> USB Hub (with 3x USB 3 + ethernet) --> LAN

1194


@arencambre wrote:

...disabling the Energy-Efficient Ethernet setting makes a little sense as it could affect power state.


Scratch that. Still getting device drops. Even happens when no Ethernet cable is connected.

When the "you've removed a device" sound is heard, the Realtek USB GbE Family Controller device disappears from Device Manager. It then re-appears after the "you've plugged in a device" sound is heard.

I'm at a loss to explain why any device setting would cause it to disconnect and reconnect. I want to say this is related somehow to Dell software shutting down or restarting the Realtek device. I lean against it being related to Dell hardware as I don't see why the hardware itself would be targeting just one device for disconnects and reconnects.

2 Bronze
2 Bronze
1211

Similar problem reported at https://www.dell.com/community/XPS/XPS-13-9310-2020-drops-ethernet/m-p/7756073. (That is more relevant to my situation because I have a 9310.)

Right when the network cuts out, I hear the tones that indicate a device was disconnected. Then a few seconds later, I hear the corresponding tone for a device being connected, then shortly after that, I regain an Ethernet connection.

Responding to above messages, disabling the Energy-Efficient Ethernet setting makes a little sense as it could affect power state. However, changing the Speed & Duplex setting doesn't make sense: how does negotiating an Ethernet connection have much to do with whether the computer thinks the device is present?

A common thread in all these complaints seems to be a USB-connected Realtek Ethernet device.

1355

We have the same issue on 4 new Dell XPS 13 laptops (BNX93005)!

We have Philips 34" widescreens with wired ethernet, connected to the USB-C port on the laptops. The ethernet connection drops a couple of times a day, usually during TCs.

Unplugging, connecting to wifi and then reconnecting to USB-C usually works, but sometimes we need to restart.

Seems to be a common issue and Dell needs to provide a solution urgently.

1407

some news/solutions on that topic??

1477

I have same issue on my new Dell docking station Dell WD19-130w / WD19TB and VAVA USB-C hub.

1725

I also have this issue using a usb c adaptor - VAVA adaptor RJ45, keeps losing internet connectivity very frustrating, will try the suggested solution and report back...   tx Paul

Latest Solutions
Top Contributor