2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

I can confirm that it worked with the BIOS version 1.0.6 csb-c to HDMI perfectly.

after a BIOS update after version 1.0.6 this error occurs.

Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Hello all,

Just to confirm that I have the same issue.
I'll try to downgrade BIOS.

So disappointed with this XPS 13.
Have it for 3 weeks and I have already opened 4 support cases...

Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Just received my replacement laptop after almost 3 weeks.  It came with 1.0.6, and the adapter works perfectly.

Warning to all:  MS Windows Update will force firmware updates.  It installed 1.0.7 without any consent from me, but thankfully the adapter still works on 1.0.7.  I have since changed the group policy to disable driver updates via MS Windows Update.

Not particularly happy about having the firmware forced upon me.  At least they went in sequential order and did not go straight to 1.0.11 

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

I tried a little and got it so that I have BIOS 1.0.6 on the system again and the Embedded Controller on firmware version 1.0.1.
So i can use the right Thunderbolt 3 port again for USB-C to HDMI.
So i can even address a TV again via HDMI cable.

I think that this whole topic started with the BIOS 1.0.7 because the Embedded Controller was fueled with firmware from Dell.
I think it was 1.0.5 EC firmware.

Currently I have all changes from BIOS 1.0.11 in the system regarding the firmware only the primary embedded controller has firmware 1.0.1 so it works on the right side.

but this is not a satisfactory solution for a 2000 € device and i think that a USB-C 3.1 Gen2 port in a portable device has to accept any adapter without restriction.

 

The system is freshly installed wiht Windows Build 2004. 

Bios 1.0.6Bios 1.0.6EC Firmware 1.0.1 -- 1.0.5EC Firmware 1.0.1 -- 1.0.5

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

@_Shade_ what version of the Main System TI Port Controller 0 and 1 drivers do you now have? Whatever I try (downgraded the BIOS to 1.0.6), I am stuck with version 1.8.7.39 of those drivers, rather than the previous 1.6.5.36 version, and my adaptor therefore doesn't work, even though the embedded controller is back to version 1.0.1

0 Kudos
Highlighted
3 Argentum

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

@_Shade_Interesting, I did a flash back as well and got 1.0.1, but I still experienced the same issue. Repeated re-flashing also did not solve things.

Though, I noted there were certain occassions where a problematic adapter would somehow work, but only temporarily. It would 'reset' thereafter.

0 Kudos
Highlighted
3 Argentum

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

@LiquidIce012 I believe there's a setting in BIOS to disable capsule updates or something. That should prevent the forced firmware updates.

@AbbasB mine is the same version as you now, as seen in the screenshot.

 

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

I did some tests again and noticed that when the power cable was connected on the left side the USB C to HDMI adapter on the right side was not working properly.
So connect the power cable to the USB-C adapter and wait until the monitor is recognized and then connect the power.

Of course I also tested a USB-C to DisplayPort cable. This works perfectly up-to-date in every situation.

It doesn't matter which BIOS I'm running, the HDMI adapter hits more.

At the end of my test I even had both external monitors connected, one via DisplayPort and the other via HDMI.

DP & HDMI WorksDP & HDMI Works

I also tested a DELL DA200 adapter with no problems.Ethernet, HDMI, USB, VGA adapter.

Furthermore I also connected a DELL WD19TB which was recognized and used without any problems.

Unfortunately it is not possible to send more than 60 Hz to the external monitor via these devices.

 

@AbbasB  yes i have the same firmware as you can see in the screenshot.

0 Kudos
Highlighted
6 Indium

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

@describee  and others, just an update on the escalation report I submitted about this, as I mentioned in a post on Page 3 of this thread.  I just got a phone call from a member of the Customer Quality Management Team about that report.  He confirmed he's the right person to handle cases like this, but since he's going to be on vacation next week, he's going to send it to the "Advanced Resolution Center" before he leaves so that it hopefully gets some traction in the meantime, and then he'll keep working it when he gets back.  Obviously I can't promise any results here, and even if results arrive, keep in mind that this will still likely take time since it will involve identifying underlying cause, developing a fix, testing it, etc.  But hopefully this is at least a step toward resolution. 🙂

Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

@jphughan That's good, but a greater sense of urgency on Dell's part would be welcome given how debilitating it is with so many people WFH and unable to use an external screen due to this problem.

Thank you for pushing and here's hoping they get their skates on with a solution.

0 Kudos