Highlighted
3 Argentum

XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Hi there,

Just updated my BIOS to 1.0.10 this morning. It apparently updates the firmware of the TB3/USB Type-C port. Probably solves some Power Delivery issues. 

Unfortunately, after the update, DisplayPort is no longer working properly over USB Type-C. I have tried four different adapters, and only one works sporadically after the update.

2020-05-20 (3).png2020-05-20 (4).png

I did a search on Reddit and apparently I am not alone.

I am unable to downgrade the BIOS back to 1.0.7 despite having "allow bios downgrade" option enabled in BIOS. Some of the updated firmware do not roll back.

Anyone having these issues too?

Reply
(1)
114 Replies
Highlighted
3 Argentum

This worked fine for me (the aluminium version): https://www.cablematters.com/pc-1053-122-aluminum-usb-c-to-hdmi-adapter-4k-ready.aspx

 

It should be available on Amazon too

0 Kudos
Reply
Highlighted
2 Bronze

So if you say the BIOS update revealed a mainboard flaw in your case, I wonder what the recourse is for those like me who do like the machine, but have not/will not update the BIOS since everything is working now.  If DELL is not seeing the BIOS update as the issue, am I stuck on version 1.0.6 forever?

0 Kudos
Reply
Highlighted
2 Bronze

Dell is seeing the BIOS update as an issue and there are various reports on this thread of people (including me) who have been in touch with Dell support who told them they were working on an update (with no ETA).

So once the update is released and confirmed to fix the issue, you can safely update.

0 Kudos
Reply
Highlighted
2 Bronze

ok, I understand.  @_Shade_ mentioned a response that did not fit what you had mentioned.  They made it sound specific to a board issue in that machine for replacement.  The other discussions here seem like multiple iterations of adapter blaming.  Please forgive my misunderstanding that Dell is working on something.  I was not getting that feeling from the 11 pages of discontent.

0 Kudos
Reply
Highlighted
2 Bronze

Hello everybody,

I communicated a little with the Dell Level 3 Support and was sent a Dell USB-C to HDMI.

This adapter works with the latest BIOS 1.0.11 without any problems, any combination with AC or without AC everything works perfectly.

Of course, this raises the question for me why do these third-party adapters only work if you feel like it?

Why is alternate mode so difficult to implement?

Long talk short story.

With this Dell adapter I was given a solution that worked for me. maybe there is also the possibility for you to get a Dell adapter as a solution.

In summary I am on BIOS version 1.0.11 and all functions like USB-C to HDMI work.

I also think that the Dell USB-C to DisplayPort on the XPS 13 9300 works properly.

Ask the support if he will send you an adapter for testing of course as a solution for free.


Best _Shade_

0 Kudos
Reply
Highlighted
2 Bronze

This "solution" is only a workaround though. 

 

First, of course it should work with any other adapters as it's even working on much cheaper machines.

 

Second, people already spent literally hundreds of $$ on adapters. 

Third - it's nice to be able to use not-so-expensive docking powert-through stations saving one thunderbolt port. 

 

It should just work... otherwise it's a faulty machine, can't see it any other way really 😕 

Reply
Highlighted
1 Copper

Those adapters bought via amazon from Bauihr also work (Bios: 1.0.11):

  • Bauihr USB-C HDMI 4K + USB-C VGA 1080P + HDMI VGA FHD (17 €)
  • USB C to HDMI Kabel (13 €)

 

0 Kudos
Reply
Highlighted
2 Bronze

@_Shade_ 

 

Thanks for the suggestion - I have purchased the USB-C to DP adapter from UNI and I can confirm it works. 

 

Thank you for the work-around!

0 Kudos
Reply
Highlighted
1 Copper

I'm on Ubuntu 18.04 and this USB-C hub only works for HDMI and ethernet - additional USB devices plugged in don't work https://www.amazon.com/Adapter-Charging-Ethernet-Compatible-Thunderbolt/dp/B07TVSLDND/ref=pd_rhf_ee_...

0 Kudos
Reply
Highlighted
2 Bronze

I also have the UNI USB-C for DisplayPort and it works for me.

I can only tell you one thing that the Dell XPS 13 9300 manual states that this is the only supported DisplayPlay Connector USB-C to DisplayPort.

A hardware defect could really play a role with you.

0 Kudos
Reply