Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

@Kyle Sh. Dell reached out to me via Twitter this morning to ask me try BIOS 1.1.0.  Still does not work with my 3rd party adapter.  Waiting on them to respond. The person I've been communicating with thru Twitter stated they are a L3 engineer and their primary role in REC is investigating this issue.

0 Kudos
7 Gold

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

Well I got an answer back from the escalation path I was pursuing, and it didn't make sense.  They were talking about only being able to output 30 Hz on both new and older BIOS versions and therefore suggesting limitations on the adapters.  I replied asking whether anybody involved in that testing had actually read even the problem summary I sent them, never mind this thread, which makes it clear that the problem is adapters that stopped working completely after a BIOS update, not adapters that have reduced performance.  Still hoping to get an answer back on that.

As for BIOS 1.1.0, there's nothing in the release notes here about fixes for this.  Of course published release notes don't always include all fixes/changes, but given that one of the fixes mentioned was a security issue, it's possible that Dell fast-tracked a release to fix that problem and therefore other fixes planned for the "next release" got pushed.  But I don't have a way to know that for sure; that is purely a guess on my part.

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

I thought I was lucky.

On 1.0.11 and all previous versions I was able to get my Anker USB-C->HDMI adapter to output 4k/60hz relatively easily.  There were some hiccups here and there, but tweaking Ubuntu's display settings usually sorted them out and got me the correct resolution.

I just upgraded BIOS to 1.1.0 this morning and now that's broken.  My OS sees the display but the highest resolution it offers me is a bizarro 1280x800.

0 Kudos
Highlighted
7 Gold

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

Ok, better update from my internal escalation path:

BIOS 1.0.10 included a new PD firmware meant to fix other issues.  That firmware added a timing delay before the Alt Mode discovery process (e.g. for DP Alt Mode).  That delay is causing some dongles to generate some extra messages that are unexpected by the system at the time they are generated, which causes the system to abort the negotiation and thus not enter into DP Alt Mode.

Originally the BIOS team had planned to roll back the PD firmware as part of the 1.1.0 update, but now that they believe they understand root cause (above), they scrapped that plan and are currently working with Texas Instruments on corrective actions.

Highlighted
2 Iron

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

Hello everybody,

I have installed the current BIOS for the Dell XPS 13 9300 and can not make any improvement in terms of USB-C to HDMI or DP.
All tested Ugren USB-C to HDMI do not work.
I also found that the firmware in Windows Device Manager does not yet have the correct driver due to the update. A manual search for the Windows update catalog was not successful.

My USB-C to DP from UNi continues to work without problems.

@ 60Hz
@ 144Hz
@ 240Hz


I hope that Dell sharpens here in the interest of the customer and that we are all happy again.
I can only say everyone opens a ticket and escalates the topic.
I also found that only the BIOS changes but no changes are made to the firmware of the EC and PD ports.

See the Screenshots 🙂

Beste _Shade_Only Bios Version ChangedOnly Bios Version ChangedNothing ChangeNothing ChangeUNi USB-C TO DP @ 144HzUNi USB-C TO DP @ 144HzFirmware on Windows SideFirmware on Windows Side

0 Kudos
Highlighted
3 Silver

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

@_Shade_  which device specifically shows it does not have the correct driver? Maybe this is something we can dig into more... I've noticed drivers are often missing from the dell profile for whichever laptop/service tag you are looking at. Maybe something else exists that we don't know about yet.

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

@jphughan @Kyle Sh. 

My contact also responded that the PD firmware needs to be updated

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

Also experiencing issues with USB-C docks on my 9300

1.1.0 seemed to help at first but seeing issues again after just a few minutes.

Using a plugable UD-ULTC4K with latest drivers, fully updated windows and BIOS.

 

Thank you former posters for doing the work of communicating with Dell. I'm glad to see they're working on a fix for the Power Delivery and USB-C subsystems - just wanted to throw my hat in the ring as another affected customer.

 

0 Kudos
Highlighted
3 Silver

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

I need to correct myself from earlier - the new bios DOES improve this. Certain docks that did absolutely not work previously now work sometimes. It takes a lot of unplugging/replugging and trying again.... but it works sometimes!! For some reason, I have better luck with the port on the right side of the laptop compared to the left side...

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

Behavior is the same for me, but instability (both or one monitor dropping) starts up quickly even in instances where I can get the docks to connect on 1.1.0 - as though different devices are being selectively suspended (USB selective suspend not in power options so cant turn this off to test).

0 Kudos