Highlighted
3 Argentum

XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

Hi there,

Just updated my BIOS to 1.0.10 this morning. It apparently updates the firmware of the TB3/USB Type-C port. Probably solves some Power Delivery issues. 

Unfortunately, after the update, DisplayPort is no longer working properly over USB Type-C. I have tried four different adapters, and only one works sporadically after the update.

2020-05-20 (3).png2020-05-20 (4).png

I did a search on Reddit and apparently I am not alone.

I am unable to downgrade the BIOS back to 1.0.7 despite having "allow bios downgrade" option enabled in BIOS. Some of the updated firmware do not roll back.

Anyone having these issues too?

1 Solution

Accepted Solutions
Highlighted
7 Gold

Re: 4th September will be the day. Or will it?

Jump to solution

@Tpholloway  Sorry, totally forgot to address the BIOS question after all of that!  The latest BIOS as of this writing, which just came out yesterday, can be downloaded here.  But as an easier and more comprehensive general solution, just install Dell Update from here.  It's basically Windows Update for drivers and firmware, so you can use that at any time to see whether there are any updates available for your system.  You might find that the new BIOS solves your issue without you having to buy anything else -- although that "mini-dock" I mentioned in my previous reply is a great thing to have on hand when you have a system that only has USB-C ports (which is one of the reasons I'm grateful to have a system with dual USB-C/TB3 ports AND a nice set of other ports.)  Good luck!

View solution in original post

0 Kudos
195 Replies
Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

Bump.  We can't be the only ones having this issue.  When can we expect a BIOS fix?

Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

I also have the same issue as well. Would appreciate any troubleshooting methods if available

Highlighted
3 Argentum

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

Could you guys list down the problematic adapters you are using? Thought it might be useful for the engineers to troubleshoot. So far I've had issues with roughly half of my adapters. I had no problems previously.

Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

@describee Mine is Anker USB-C to HDMI 4k @ 60Hz 

I also had no problems prior to the BIOS update. Worked perfectly fine with all my monitors and TV. Does not work anymore.

My fiance's work laptop (Thinkpad) will output with the Anker adapter.

Even tested her laptop on my Dell P2421DC via HDMI. Thinkpad will output fine, XPS13 will NOT output. 

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

@describee @JayKay808 

BIOS 1.0.11 is available.  I won't be able to test it for a few hours and I will be shipping it to Dell later to fix my Webcam.

0 Kudos
Highlighted
3 Argentum

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

@LiquidIce012 I just flashed but it didn't seem to fix things 😞

0 Kudos
Highlighted
3 Silver

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

I can confirm as well that my adapters (USB-C to HDMI) is not working now. My Dell dock, however, DOES work...

I have another type-c hub/dock arriving today, so I will let you know what happens with that one.

0 Kudos
Highlighted
3 Argentum

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

@Kyle Sh. Just to confirm you had no issues on 1.0.7, and the newly released 1.0.11 doesn't solve it?

Which hdmi adapter are you using?

0 Kudos
Highlighted
3 Silver

Re: XPS 13 9300, BIOS 1.0.10, USB Type-C to DP adapters no longer work

Jump to solution

Correct - no issues before, but now it will constantly say the USB device is not recognized, etc.

The adapter doesn't seem to be sold on Amazon anymore, but it's name was: TechOrbits Thunderbolt 3 USB C Type C to HDMI/PD to Female 2-in-1 Adapter Converter Cable HDMI 4K and Type C charger Alumium Finish compatible with 20

Pretty basic USB-C to HDMI adapter. Worked fine before with multiple computers/phones.

EDIT: My bad, I did not realize there was another bios update today. I am still on 1.0.10. I will update and let you know if anything is fixed for me.

0 Kudos