Highlighted
2 Bronze

XPS 13 9300 thunderbolt 3 issue

Hi, I have bought the new XPS 13 9300 and I wanted to connect it to my ultrawide monitor. I have tried 3 different ways: usb-c, thunderbolt (my monitor has a tb3 input) and through a TB dock. In all 3 ways the laptop would start and stop charging frequently and also disconnect from the external monitor. What I noticed is that this problem would go away as soon as I plug in the charger. Which shouldn't be the case as my monitor as well as the dock provide 85w. What could be the problem? I am going crazy as this was the reason to buy the XPS 

Labels (3)
Reply
89 Replies
Highlighted
2 Bronze

Same issue on the XPS13 9300 connecting to my Samsung C34J79 monitor, worked fine with my old 9350 and 9370 in use in the family here, same cables. worked fine on day 1 only...

Looks like either a temperamental port hardware issue or drivers.

If it’s hardware, then it will not get better. I’ll return my unit if this is unresolved by the end of the month.

0 Kudos
Reply
Highlighted
1 Copper

Hi @RobSkipworth, I have the same exact monitor and just ordered the XPS 9300 (currently being shipped). Did you manage to solve the problem or did you return the laptop in the end? If the laptop cannot display and charge through the same port and cable that makes it DOA for me.

0 Kudos
Reply
Highlighted
2 Bronze

Hi @sansantb - No progress by Dell I'm afraid, one BIOS update since but no change and, can you believe I've 5 XPS 13 in the house (three previous version 9370 and a a couple of my real old ones) - all work fine with all monitors in the house on USB-C -  for charging via the monitor and monitor signal. Not the 9300 though...

I'll be returning mine once we're out of lockdown here in Spain too. Having to use an adaptor to HDMI and that means I'm having to charge via the right-hand USB-C meaning I have to charge for a while the swap out for my USB-C camera for conference calls and then back again to charge...

 

0 Kudos
Reply
Highlighted
2 Bronze

Hi,

I also have a similar problem with my new Dell 9300.

I have a Samsung 32 inch quad hd widescreen monitor and using usb-c thunderbolt connection to charge my laptop.

However, nothing is displayed on my external monitor when I connect via thunderbolt. I have updated BIOS, video and thunderbolt drivers.

The only way to get it working... 50% of the time is to restart my laptop with the connection already in place.

I do not have this problem with my previous Dell  XPS 9350 model.

Can anyone from Dell advise?

0 Kudos
Reply
Highlighted
3 Argentum

@davdatongJust some questions:

  • Is your model the Samsung CJ971?
  • Some mentioned their TB3 display works when the other TB3 port is connected to a power adapter. Does this resolve your issue?
  • Have you tried both the 85W and 15W TB3 ports on the monitor?

Also you might wish to contact Dell directly or start a new thread so that Dell can log the case for you from there.

0 Kudos
Reply
Highlighted
2 Bronze

@describee I am using a Samsung CF791 Series widescreen monitor.

Nope. Didn't resolve my issue with the power cable plugged in and I've tried both 85W and 15W although I don't think it will work with 15W.

@Philskies .. Yes. I've got exactly the same issue as you with all BIOS updated.

I've raised a ticket with Dell and they mentioned that there will a new BIOS available which resolves display issues with thunderbolt. However, the release date for this is in May!

It will be great to raise a ticket with Dell if you haven't already as we maybe able to escalate  this with more tickets raised.

Reply
Highlighted
3 Argentum

@davdatongNow I am confused, because the CF791 doesn't have any Thunderbolt 3 ports?

0 Kudos
Reply
Highlighted
2 Bronze

@describee. Yes, mine has a thunderbolt connection. Exact model: C34J791 and purchased in UK Currys.

https://www.currys.co.uk/gbuk/computing/pc-monitors/pc-monitors/samsung-c34j791-quad-hd-34-curved-le...

0 Kudos
Reply
Highlighted
2 Bronze

Dell 9300 External Monitor problem – and maybe an indication of a more grave Thunderbolt issue on the new XPS13 and XPS15…

Can you believe I've 5 old XPS 13 in the house (three previous version 9370 and a couple of older ones) - all work fine with all monitors in the house on USB-C - for charging via the monitor and monitor signal. Not the 9300 though... exactly the same Samsung Thunderbolt monitors and LG too.

I'll be returning mine once we're out of lockdown here in Spain too. Having to use an adaptor to HDMI and that means I'm having to charge via the right-hand USB-C meaning I have to charge for a while the swap out for my USB-C camera for conference calls and then back again to charge...

I’ve seen lots of report of problems with the Thunderbolt on this model – and maybe the 15 inch too..

Some have said the monitor works as long as the power is on to the laptop (so you’d have to power using the only other USB-C Port!!)

Monitors: 34wk95u and the SAMSUNG C34J791 and, again, these work with the last two generations of XPS13.

0 Kudos
Reply
Highlighted
2 Bronze

"I've raised a ticket with Dell and they mentioned that there will a new BIOS available which resolves display issues with thunderbolt. However, the release date for this is in May!" @davdatong 

Has anyone heard any updates on this? I'm having issues with this as well.

0 Kudos
Reply