Highlighted
2 Bronze

Re: XPS 13 9300 thunderbolt 3 issue

@describee Thanks much, looking for a 32" model, I'm settling on the Dell 3219Q, hopefully will be a one cable solution.

0 Kudos
Highlighted
2 Iron

Re: XPS 13 9300 thunderbolt 3 issue

@saswett there's a new BIOS update today which fixes some PD issues. Not sure if it helps your case?

 

Note: the new bios has some compatibility issues with certain USB-C to DP adapters.

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300 thunderbolt 3 issue

@describee Thanks. I ended up returning the TB3 monitor and purchased the Dell 3219Q USB-C monitor. It works just fine with a one cable solution, to include power delivery. Too bad the TB3 monitor didn't end up working.

0 Kudos
Highlighted
2 Iron

Re: XPS 13 9300 thunderbolt 3 issue

@saswett that's great to hear! And hopefully that indicates more of a firmware/bios issue that could be fixed in future...

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 9300 thunderbolt 3 issue

@describee It very well could have been a problem with the monitor's software, and not the XPS 13 9300. I was unable to pinpoint the issue. LG did assure me they opened a ticket to try and fix the monitor's software, with no projected completion date.

A warning to other XPS 13 900 users: do not buy the 32UL950 !

0 Kudos
Highlighted
1 Copper

Re: XPS 13 9300 thunderbolt 3 issue

@davdatong 

Hey thanks for your information. I think we have the same issue. Using your information, I tried turning on my 9300 with the cable already plugged in and it works. So far 2 out of 2 times.

I tried removing the cable and plugging it back in while powered on, and it starts disconnecting/reconnecting again.

I also tried a "restart" instead of a shutdown, and it starts disconnecting/reconnecting.

Like you, my 9350 works fine, and I've also updated all my drivers. The only difference is that we use different monitors and hubs.

0 Kudos
Highlighted
2 Iron

Re: XPS 13 9300 thunderbolt 3 issue

@Philskies You are having the issue even when the USB-C plugged directly in to the laptop? If so, please contact Dell -- you have a Dell monitor and a Dell laptop -- chances are, they would be more willing to fix this.

0 Kudos
Highlighted
1 Copper

Re: XPS 13 9300 thunderbolt 3 issue

I have dell xps 13 that I bought a year ago, connected to a Caldigit and 2 Dell monitors.

Everything was working fine until yesterday when my xps13 received a forced window update.

 

Since then I can't connect my xps to cal digit using just a thunderbolt 13 without also connecting it to charge.

I spoke with both DELL and Xaldigit, and turnout that with the new update Dell is not allowing third party charging. 

 

I am really disappointed I am a business owner that all I used was dell product but now I am considering Mac. 

Highlighted
1 Copper

Re: XPS 13 9300 thunderbolt 3 issue

Some issue with currently all my thunderbolt 3 docks. It's a really nice device otherwise. But I'll have to return it.

0 Kudos
Highlighted
1 Copper

Re: XPS 13 9300 thunderbolt 3 issue

Same issue here. Latest Bios and Drivers as of May 24, 2020. I have an LG 34WK95U-W which I use daily with a Precision 5520 and a Dell TB-16 Thunderbolt Dock (The Monitor does not deliver enough power).  When I connect my XPS 13 9300 I either get the constant disconnect/reconnect, no video at all, or if I'm really lucky, I'll get 1440P on the 5K monitor. All devices on the dock do connect and the monitor is set to DP 1.4.  I have the same issue when I connect directly to the monitor, though usually it's the repeated disconnect/reconnect only. 

I have another Dell WD-15 USB-C dock on an older U2711 Dell monitor and it all works fine. That dock does not support 5K though DP or HDR, so it's useless in the setup I'm trying to use. Have high hopes this can be resolved with software, love the laptop otherwise.

0 Kudos