Highlighted
2 Bronze

XPS 13 9300 thunderbolt 3 issue

Hi, I have bought the new XPS 13 9300 and I wanted to connect it to my ultrawide monitor. I have tried 3 different ways: usb-c, thunderbolt (my monitor has a tb3 input) and through a TB dock. In all 3 ways the laptop would start and stop charging frequently and also disconnect from the external monitor. What I noticed is that this problem would go away as soon as I plug in the charger. Which shouldn't be the case as my monitor as well as the dock provide 85w. What could be the problem? I am going crazy as this was the reason to buy the XPS 

Labels (3)
Reply
89 Replies
Highlighted
2 Bronze

I returned the 9300 in the end as the thunderbolt to my monitor just didn't work after an update. The technical support did not make any effort in fixing except pushing me to get the refund.

Good looking laptop. However, the laptop is riddled with problems.

Replaced now with a Huawei Matebook X Pro and everything is working fine.

 

0 Kudos
Reply
Highlighted
3 Argentum

@davdatong thanks for the update and pity about your experience with the XPS 9300.

0 Kudos
Reply
Highlighted
1 Copper

If only I had seen this thread before I bought the XPS 13 9300 and the LG 32BL95 (same as LG 32UL950 but from the business lineup).  I purchased this laptop and monitor for the exact reason as the OP... a single cable solution with all the benefits of Thunderbolt 3. 

 

Unfortunately, I am experiencing the exact problem.  Any time the laptop tries to use Power Delivery from the monitor, there is constant connect/disconnect loop.  SOMETIMES (~10% of the time) this connect/disconnect loop stabilizes in an end state of monitor connected, laptop indicating plugged in, but not charging!  The monitor works fine if the laptop is either connected to the included Dell power supply or a powered USB-C Dell dock I have.

 

I'm disappointed and in a situation where I cannot easily return either item... and despite this issue I love each item individually!  I hope Dell/LG fix this!

0 Kudos
Reply
Highlighted
2 Iron

I assume you have tried updating bios and all the various drivers?

I really don't know what changed in my setup apart from bios updates which I'm sure went through a while back but then again I had another today so who knows.

Either way, running the D6000 via the usb-c port suddenly started to work and gone were the power loops.

Right now I'm typing on a bluetooth keyboard / mouse connected to the D6000 and can see the laptop is charging too.  This is with 3 additional monitors connected to the D6000 so in total 4 including the laptop screen.  Does the first series of flashes as it detects the various screens and then its stable.

0 Kudos
Reply
Highlighted
2 Bronze

I have had a lot of similar problems with my XPS 13 9300 connecting to external screens. First problems to connect and then going black after a few minutes. I've tried 4 different docks and many different ways of connecting the screens without success. Everything is working perfectly fine with my older XPS 9370.

Check my thread for additional info: https://www.dell.com/community/XPS/XPS-13-9300-Thunderbolt-docking-problems/m-p/7616265#M62972

0 Kudos
Reply
Highlighted
2 Bronze

I wish I saw this post before getting the laptop... I use TS3 plus and end up with the same issue. This is really a huge problem given it only has 2 tb3 ports for port extension. And it's just funny that dell paid no attention to this issue because most people won't have a tb3 device in 2020.

0 Kudos
Reply
Highlighted
2 Bronze

I bought my machine in HK and they refused to admit the issue and also refused return and refund even though the machine basically has functional defects. I'm gonna contact my local consumer council. This has been my worst shopping experience.

0 Kudos
Reply
Highlighted
1 Copper

Having same issue with XPS 13 9300 (BIOS version 1.0.11) + LG 34WK95U-W (85W PD) 

Works good with second charger connected, but 1 cable connection leads to regular connect/disconnect.

My old XPS 13 9350 works smoothly with the same display 

 

 

0 Kudos
Reply
Highlighted
2 Bronze

I'm chiming in to say I'm having the same issue as well. 2 months of ownership on my 7th Dell now, all of them have display issues. My XPS 9300 won't output to a second display (Tried Samsung 27", Sceptre 27" and LG 32"), but my 9370 and 9380 both have no issues displaying to the same monitors. The ONLY monitor it will correctly display externally is a Dell U3219. All drivers/bios are up to date as of today.

0 Kudos
Reply
Highlighted
2 Bronze

So what is the current status? 

I've got 4k monitor which is pretty much unusable for me right now. 

It works well even with £400 dell inspirion, but cannot make it work with xps. 

Should I just check for bios upgrade with no ETA on it? 
This is large issue DELL, I am utterly frustrated 😕 

0 Kudos
Reply