XPS

Last reply by 09-05-2018 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 9333, no bootable devices found

Have an XPS 13 9333, Windows 10 installed, boot drive is liteonit LMT-256L9M-11 MSATA 256GB SSD.  

Using UEFI boot with security enabled.  Tried legacy boot on Windows 10 USB media, still can't see hard drive.

When booting comes up with above message, option F2 for bios, F5 for diagnostics.

The hard drive passes extended diagnostic tests, and appears correctly in the BIOS configuration.  BIOS version is A06.

If I load Windows 10 from USB media the hard drive cannot be found, X: and C: drives are both the USB, no other drives found.

Have checked other solutions as posted in this forum, and either assume hard drive is visible, or otherwise have no impact.

thanks

 

Replies (8)
2 Bronze
2 Bronze

if there is no bootable device found in you Dell computer, you might think about the following possible causes: incorrect boot order, partition not set as active, hard disk failure or corrupted mbr.

For each cause, you can do as follow:

1.to change the boot order:

1) Press the Power button and keep pressing F10 to enter BIOS. (the key could be ESC, Delete, F1, F2, depending on which computer you are using)

2) Press the arrow key on your keyboard to get Boot tab, and change the boot order settings to make Hard Drive as first boot device.

3) Follow the instruction given to you in the BIOS utility to navigate to Exit tab.

4) Locate and choose the Exit Saving Changes option to save the changes you made to the boot order.

5) Follow the prompts to restart your computer.

2. Reset primary partition as active

If the primary partition is not set as “active”, then the no bootable device will occur. So please reset your primary partition as active using the Diskpart and running some commands.

First, insert the Windows installation media (DVD disk or USB flash drive) and boot your computer from that, then under System Recovery Options or Troubleshoot, click Command Prompt, finally type the following commands in sequence and hit enter after each: diskpart -> select disk 0 -> list partition 1 -> active.

3.Repair corrupted boot files

1) Insert the boot disk into your computer and boot from it.

2) Select the language and region, and then click Repair your computer.

3) In a Windows 10 (or Windows 8.1, Windows installation media, select Troubleshoot and then Command Prompt. In a Windows 7 installation media, in System Recovery Options, select the first item and Windows 7 as the operating system, click Next and then Command Prompt.

4) In Command Prompt, type the following commands one by one and hit Enter after each one. (If you are asked whether you want to add a new installation to boot list, press Y and then hit Enter.)

bootrec /fixmbr

bootrec /fixboot

bootrec /scanos

bootrec /rebuildbcd

These methods could help you with how to fix no bootable device.

Community Accepted Solution

Good luck.

JohnD

Thanks JohnD

It appears this is the case here, so putting it down to a dead drive.  Have a replacement (different make) on the way, and a usb docking station for the dead drive.  Will be interesting to see if anything is readable on the dead drive besides not being able to boot from it.  Will post in a week or so with outcome.

It looks like your drive has a problem. In googling around, I found some issues with that drive. You might want to look at this post by someone with the same drive: Advice sought on possible failing drive

This person had the same problem but it was intermittent. Diagnostics also showed no problem.

JohnD

Thanks JohnD

Downloaded Macrium Reflect and ran.  From instructions it was not able to find any installed windows operating systems, so was not able to proceed.

The issue seems to be that the hard drive is configured, and passes the Dell hardware test, but is not mounted when Windows 10 (or recovery media) load.  It's not that it is corrupted (although it may be), it's just not there. 

glmmph

 

Something you could try:

1. Download and install the free version of Macrium Reflect on a computer that is working.

2. Create the Macrium Reflect Rescue Media to a USB drive.

3. Boot to that media and execute the "Fix Windows Boot Problems". Instructions here.

I have used that to fix some computers with boot problems. Hopefully it might fix your problem.

Good luck,

  JohnD

 

No, the BIOS has not been updated lately.

3 Zinc

Did you recently willingly (or unwillingly) do a BIOS update?

Top Contributor
Latest Solutions