1 Copper

XPS 13 9350 - Thunderbolt port no longer showing in OS (USB-C Port Fried?)

I have access to several XPS13 9350 (my own, my wife's, my mother's). They all run Arch Linux, and all charge using USB-C chargers. I have a "CHOETECH USB C to HDMI Adapter(4K@60hz), USB Type-C HDMI Female Adapter with 60W PD Charging Port Thunderbolt 3" that I have used to connect our laptops to HDMI TV's.

Recently my laptop stopped recognizing the HDMI adapter when I plug it in. I used the linux tool fwupd and found on my wife's working laptop it shows 2 devices: "XPS 13 9350 Thunderbolt Controller" and her 'Samsung NVMe SSD'. While my non-working laptop 'fwupdmgr get-devices' only shows my 'Samsung NVMe SSD'.

I tried updating to the latest BIOS, reset the BIOS settings, and tried every combination of the Thunderbolt related settings but that has not made a difference. I would try updating the thunderbolt firmware, but I don't think that is possible unless the device shows to the OS.

I have a feeling the thunderbolt chip got fried from always using USB-C to charge. Any advice what else I can try? Thank you for any help.