lamer01
1 Nickel

XPS 13-9350, won't turn on properly

I have a power up issue. Tried all the solutions provided (removing bios battery and Li-On battery). Laptop still seems dead. It powers on but not 100% I think as the power light goes on and stays on. The backlit keyboard goes on. A usb stick that I plugged in seems to get power. When I remove the bios battery back up it blinks 3 amber 1 white to tell me that it has no bios battery. When I shut it down by holding power, the fans run briefly. When I plug into external monitor I get no signal though. Any other ideas?
0 Kudos
2 Replies
lamer01
1 Nickel

Re: XPS 13-9350, won't turn on properly

I have the same issue. Tried all the solutions provided. Laptop still seems dead. It powers on I think as the power light goes on and stays on. The backlit keyboard goes on. A usb stick that I plugged in seems to get power. When I remove the bios battery back up it blinks 3 amber 1 white to tell me that it has no bios battery. When I shut it down by holding power, the fans run briefly. When I plug into external monitor I get no signal though. Any other ideas?

0 Kudos
lamer01
1 Nickel

Re: XPS 13-9350, won't turn on properly

I get 3 amber/yellow blinks and 1 white. I saw some list where it says that means CMOS battery so I got a new CMOS battery.  That did not help. Also, I got a used MB on ebay. That MB is doing the exact same thing. How is that possible? Does anyone know exactly what 3 amber 1 white blink means?

Thx

p.s. A couple more hints. It behaves the same with or without the internal battery plugged in. Is it supposed to work with just the adapter plugged in when there's no battery? If not, maybe I need a new battery. I don't want to blow money on that without some confirmation.

0 Kudos