ennyta
1 Nickel

XPS 13 9360 with BIOS 2.7.1. "hard drive not installed"

Got my laptop in February 2017 and it was working normally till about 3 months ago. Then whenever restarted, it enters bios and shows message "Hard drive - not installed". 

If I continue, it normally just turns off and I have to start it again. Sometimes it starts straight away, sometimes I have to repeat this process a few times.

I tried a few solutions suggested for this error (from https://www.dell.com/community/Laptops-General/XPS-13-9360-freezes-and-shows-quot-Hard-Drive-not-ins...). SupportAssist doesn't show any problems, drivers are up to date.

Anyone experienced the same problem and if so, what did you do to fix it?

5 Replies
Highlighted
ejn63
5 Rhenium

Re: XPS 13 9360 with BIOS 2.7.1. "hard drive not instal

Run an extended diagnostic on the drive - F12 at powerup.

 

ennyta
1 Nickel

Re: XPS 13 9360 with BIOS 2.7.1. "hard drive not instal

Already did, forgot to mention in the question. It reports no errors.

0 Kudos
ejn63
5 Rhenium

Re: XPS 13 9360 with BIOS 2.7.1. "hard drive not instal

How long did the test take (you want the extended test, which will take a couple of hours)?

0 Kudos
ennyta
1 Nickel

Re: XPS 13 9360 with BIOS 2.7.1. "hard drive not instal

It says in logs it is extended test. It took about half an hour. I run it again and the result is the same, no errors found.

0 Kudos
jeanjacques1
1 Copper

Re: XPS 13 9360 with BIOS 2.7.1. "hard drive not instal

I have the same issue. Dual boot with Linux, weirdly it only says hard disk not installed on booting grub - windows boot manager works fine. Please solve this - this must be the third time a dell/windows update breaks my system.

0 Kudos