XPS

2 Bronze

XPS 13-9365 2-in-1, not able to upgrade BIOS

Hi, My XPS 13 9365 2-in-1 is stuck on BIOS version 1.2 and I cannot upgrade nor downgrade.  I have tried to download and install manually (both within BIOS and windows) as well as using the Dell Update utility program. When upgrading it looks as it installs successfully, however when checking in BIOS (and in Dell Update program) it remains on 2.1 and continues to suggest upgrading.  I have tried 1.3, 1.4 and 1.5, even downgrade to 1.1. I’m out of ideas. Have anyone experienced the same issue and found a solution?

BR Peter

Labels (3)
Replies (18)
2 Bronze

Below you will find the log when trying to patching manually. After restart, no change.

***BIOS flash started on 7/27/2018 at 21:18:12***
Command: C:\Flash64W.exe /b=BIOS150.exe /s /f /l=c:\bioslog.txt

WSMT Not Supported: WSMT Support token not found, using legacy DACI commands
1.2.1 INSTALLED (Dell System XPS 13 9365)
- XPS 13 9365 System BIOS with BiosGuard : 1.2.1
- Intel Management Engine Unmanaged Firmware Update : 11.8
- Main System TI Port Controller 0 : 1.11.5.1
- Main System Cypress Port Controller 0 : 0.0.13
- Embedded Controller : 1.0.24


1.5.0 UPDATE (Dell System XPS 13 9365)
- XPS 13 9365 System BIOS with BiosGuard : 1.5.0
- Intel Management Engine Unmanaged Firmware Update : 11.8
- Main System TI Port Controller 0 : 1.11.5.1
- Main System Cypress Port Controller 0 : 0.0.15
- Embedded Controller : 1.0.27
- PCR0 XML : 0.0.0.1
- XPS Board Map : 1.0.1

Exit Code = 2 (Reboot Required)
***BIOS flash finished at 7/27/2018 at 21:18:27***



 

I just did the 1.5 update last week but do not show the log file you reference.  Do you have any other log files  I could check?

Did you do any during or after your last successful Bios update which might be involved in your current situation?

I found this site but I do not know if it might be relevant to your situation.

https://docs.microsoft.com/en-us/windows-hardware/design/device-experiences/oem-uefi-wsmt

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
System fully Win 11 compliant

Did you ever resolve this problem?  I'm having the same issue.

Same issue for me. Stuck in BIOS 1.3.1, can't update to bios 2.3.1. Supportassist makes you believe that it does but not really.
2 Bronze

I have same problem. Now is version 2.2 and still nothing

Can you try create request to Dell support assist? I have always problem to create one.

 

Just download SupportAssist software from https://downloads.dell.com/serviceability/catalog/SupportAssistInstaller.exe

 

And there is a option GET SUPPORT

2 Bronze

If you have enabled the security in your BIOS, you have two options:

1 - disable the password and install the update.

2 - install it manually using the password (more technical):
 2.1 - Download the executable file.
 2.2 - Open Command Line and navigate until the downloaded instalation file.
 2.3 - Execute the following command in CMD (usually the parameters are the same but if you want to make sure, run /? instead of /s/f/p/l):
        FILENAME.exe /s /f /p="BIOS_PASSWORD"  /l="C:\log.txt"

After do the above, check the result in the log location C:\log.txt

Hi aurelio_neto Thank you for your reply. I have no BIOS password. Running your proposed command does not solve the issue. The log looks good after running the command, but the bios version remains on the current version: ***BIOS flash started on 11/28/2018 at 18:59:52*** Command: C:\XPS_13_9365_2.3.1.exe /s /f /l="C:\log.txt 1.2.1 INSTALLED (Dell System XPS 13 9365) - XPS 13 9365 System BIOS with BiosGuard : 1.2.1 - Intel Management Engine Unmanaged Firmware Update : 11.8 - Main System TI Port Controller 0 : 1.11.5.1 - Main System Cypress Port Controller 0 : 0.0.13 - Embedded Controller : 1.0.24 2.3.1 UPDATE (Dell System XPS 13 9365) - XPS 13 9365 System BIOS with BiosGuard : 2.3.1 - Intel Management Engine Unmanaged Firmware Update : 11.8 - Main System TI Port Controller 0 : 1.11.5.1 - Main System Cypress Port Controller 0 : 0.0.15 - Embedded Controller : 1.0.33 - PCR0 XML : 0.0.0.1 - XPS Board Map : 1.0.1 Exit Code = 2 (Reboot Required) ***BIOS flash finished at 11/28/2018 at 19:00:12***

Hi, 

No change. I have no BIOS password. When running the command i get the same result:

Hi, 

Thank you for your reply. I'm not having any BIOS password. When running the command the log looks promising, but no success:

***BIOS flash started on 11/28/2018 at 18:59:52***
Command: C:\XPS_13_9365_2.3.1.exe /s /f /l="C:\log.txt

1.2.1 INSTALLED (Dell System XPS 13 9365)
- XPS 13 9365 System BIOS with BiosGuard : 1.2.1
- Intel Management Engine Unmanaged Firmware Update  : 11.8
- Main System TI Port Controller 0  : 1.11.5.1
- Main System Cypress Port Controller 0  : 0.0.13
- Embedded Controller : 1.0.24


2.3.1 UPDATE (Dell System XPS 13 9365)
- XPS 13 9365 System BIOS with BiosGuard : 2.3.1
- Intel Management Engine Unmanaged Firmware Update  : 11.8
- Main System TI Port Controller 0  : 1.11.5.1
- Main System Cypress Port Controller 0  : 0.0.15
- Embedded Controller : 1.0.33
- PCR0 XML : 0.0.0.1
- XPS Board Map : 1.0.1

Exit Code = 2 (Reboot Required)
***BIOS flash finished at 11/28/2018 at 19:00:12***

After rebooting I'm still on the old version :-(

Top Contributor
Latest Solutions