Highlighted
1 Copper

XPS 13 9370 - Killer Wifi keeps dropping connection

My XPS was working fine up until about a month ago when the Internet connection started dropping frequently. So frequently that I can't work on it of just be able to use the internet normally. 

I have been speaking to Dell support who are going round in circles with the suggestion that it's down to drivers or my home net config.  I have let them remote in, uninstall and reinstall the relevant drivers and surprise, surprise it's not fixed. 

I add to the frustration I've pulled the system logs and have the details on the errors that are causing the issue. However, this information seems to be beyond that which the support assistants can deal with.  

I am based in San Diego, have premium care until November. Please advise how I can talk to someone with the ability to find a solution.

ERROR 1:

Log Name:      System

Source:        Microsoft-Windows-NDIS

Date:          23/08/2019 09:41:29

Event ID:      10317

Task Category: PnP

Level:         Error

Keywords:      (16384),(16),(4),(2)

User:          SYSTEM

Computer:      DESKTOP-AK8RMJT

Description:

Miniport Killer Wireless-n/a/ac 1435 Wireless Network Adapter, {fd78cd38-e32c-455d-81dc-56f0c7092db4}, had event Fatal error: The miniport has detected an internal error

Event Xml:

 

  <System>

    <Provider Name="Microsoft-Windows-NDIS" Guid="{cdead503-17f5-4a3e-b7ae-df8cc2902eb9}" />

    <EventID>10317</EventID>

    <Version>0</Version>

   <Level>2</Level>

    <Task>2</Task>

    <Opcode>0</Opcode>

    <Keywords>0x2000000000004016</Keywords>

   

    <EventRecordID>4631</EventRecordID>

    <Correlation ActivityID="{fd78cd38-e32c-455d-81dc-56f0c7092db4}" />

    <Execution ProcessID="4" ThreadID="13624" />

    <Channel>System</Channel>

    <Computer>DESKTOP-AK8RMJT</Computer>

    <Security UserID="S-1-5-18" />

  </System>

  <EventData>

    <Data Name="IfGuid">{fd78cd38-e32c-455d-81dc-56f0c7092db4}</Data>

    <Data Name="IfIndex">28</Data>

    <Data Name="IfLuid">19985273102270464</Data>

    <Data Name="AdapterName">Killer Wireless-n/a/ac 1435 Wireless Network Adapter</Data>

    <Data Name="MiniportEventEnum">71</Data>

  </EventData>

</Event>

 

ERROR 2:

 

Log Name:      System

Source:        Qcamain10x64

Date:          23/08/2019 09:41:28

Event ID:      5002

Task Category: None

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      DESKTOP-AK8RMJT

Description:

Killer Wireless-n/a/ac 1435 Wireless Network Adapter : Has determined that the network adapter is not functioning properly.

Event Xml:

 

  <System>

    <Provider Name="Qcamain10x64" />

    <EventID Qualifiers="49152">5002</EventID>

    <Level>2</Level>

    <Task>0</Task>

    <Keywords>0x80000000000000</Keywords>

   

    <EventRecordID>4630</EventRecordID>

    <Channel>System</Channel>

    <Computer>DESKTOP-AK8RMJT</Computer>

    <Security />

  </System>

  <EventData>

    <Data>\Device\NDMP26</Data>

    <Data>Killer Wireless-n/a/ac 1435 Wireless Network Adapter</Data>

    <Binary>0000080002003800000000008A1300C00000000000000000000000000000000000000000000000000400000000000000</Binary>

  </EventData>

</Event>

0 Kudos
2 Replies
Highlighted
1 Copper

Re: XPS 13 9370 - Killer Wifi keeps dropping connection

Changing the Wireless Mode to 09 - 11 a/g/n solved it for me.

0 Kudos
Highlighted
1 Copper

Re: XPS 13 9370 - Killer Wifi keeps dropping connection

Hi, did you ever get a fix on this? I have tried numerous solutions online, including changing the wireless mode and still no avail. 

I am having a similar error in the event log as well.

0 Kudos