Last reply by 03-04-2020 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 9370, No bootable devices found

Hi everyone, I've made a huge mistake and I don't know how to fix this. I attempted to dual boot my laptop with Ubuntu - this worked fine. However, on attempting to switch to Windows 10, it just restarts the laptop to bring me back to the Ubuntu screen. Ubuntu works fine, but my Windows is completely gone, which I need for college quite badly.

I tried downloading the Windows ISO on a USB and adding it to the boot list but this doesn't work. The laptop itself says no bootable devices found. Please help me!

Reply (1)
7 Thorium

Clean-install Windows-10 (64bit)

You might have to DiskPart/clean the drive first.

F12 on boot should let you boot the installer flash-drive once.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
Community Accepted Solution
Top Contributor
Latest Solutions