Last reply by 02-26-2021 Unsolved
Start a Discussion
1 Amber
1 Amber

XPS 13 9370 USB-C hub not stopped working and now not being recognized by XPS

I purchased XPS 13 3 months ago and connected a USB-C hub with a logitech wireless mouse and keyboard. The USB-C hub connected to the XPS worked fine for 2 months with no issues. Now the XPS 13 does not recognize the USB-C when connected. I go the device manager and USB-C hub doesn't show up anymore. I uninstalled and then updated the drivers and restarted multiple times and also a hard restart holding the power button for 15 seconds. Nothing solved the problem. I know it is not the USB-C hub since it works on another computer fine and recognizes it fine. I also know the USB-C port on the XPS works with another USB-C hub, so the hardware isn't the problem. This seems to be a driver problem, but I can't figure out what driver is needed and why it was working yesterday and now it doesn't connect. I had a spare USB-C hub that I swapped in after the 1st one stopped working. It worked fine a few hours ago, now XPS does not recognize it too. Any suggestions?

Both of these USB-C hubs that worked fine  but do not work anymore



I also have a USB-C hub that is working for now




Replies (0)
Latest Solutions
Top Contributor