IG-
1 Nickel

XPS 13-9370, audio crashing

Hi,

My XPS 13 9370 has an issue where the audio might crash and stop working after a certain amount of time or after waking up the PC from sleep. This issue only applies to the laptop's external speakers, plugging in headphones will output sound to the headphones. But for the speakers the only solution that I was able to find was restarting the computer. 

I'm almost certain I've started experiencing this issue after I updated the audio drivers through the Dell Update system. I haven't had this issue before then.

Is there any known solutions?

Windows Troubleshooter reinstalled the drivers. That didn't fix the issue.
I tried to roll back drivers from device manager, device manager didn't give me the option to roll back (Option was grayed out)

0 Kudos
66 Replies
Saltgrass
4 Ruthenium

Re: Dell XPS 13 Audio crashing

If I understand correctly, both the internal speakers and a wired headset will work normally, but your external wired speakers have this problem.

Knowing the model of the speakers might help but if they had power saving controls which could turn them off, it may cause problems.  If you are selecting the incorrect device in the Waves popup when you plug it in, it may be trying to treat the speakers as a headset.

But whatever, from what you say, I would look first at the external speakers and their configuration and compatibility.

You might also check the Event Viewer to see if any log files are created regarding the situation in those situations.

 

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
aneesh120
1 Copper

Re: Dell XPS 13 Audio crashing

I have the exact same issue gald i am not alone.

brand new xps 13 9370

audio from laptop speakers stops working after sometime or after waking from sleep

tried reinstalling realtek HD drivers etc.

Only a restart will solve the issue.

Also when this problem occurs i am not able to stream any videos on google chrome 

 

 

 

Saltgrass
4 Ruthenium

Re: Dell XPS 13 Audio crashing

It is still unclear, your original post says External speakers.  If you are referring to the built-in laptop speakers, that is a different situation.

Internal or External...

If they are internal, since the same signal feeds both the internal and the audio port, it would seem the internal speakers are having some type of configuration problem or the Waves utility is not making them default.

On Settings-System-Sound, there are settings showing the default device for your current configuration.  Are those showing correctly?  If you look at the App volume and Device Preferences, are they set for Default or have you selected something other for a specific app?

The diagnostic you can run from boot would check the speakers for basic operation.  A short test may not prove anything since you problem seems to occur after a certain time period.  But there may be some relation to power saving procedures.

If it is relevant, the 9370 does not actually sleep but goes into a low power mode when the Display is off.  Some music utilities may continue to play with the screen off and same may pause.

 

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
Highlighted
IG-
1 Nickel

Re: Dell XPS 13 Audio crashing

Very sorry about the confusion, I did not mean external speakers. Very bad choice of words on my part.

I meant the laptop's own speakers. Laptops own speakers will not work after some time or after waking from sleep. Only solution I found is to restart the computer. Plugging in headphones works fine, as soon as you unplug them the speakers do not output anything.

Once I experience the same issue again with the sound going out (Hopefully not but that's unlikely), I'll make sure to try your suggested troubleshooting. But for now, there doesn't seem to be an issue with the configuration (Settings>Setting>Sound, App volume and device preferences)

0 Kudos
IG-
1 Nickel

Re: Dell XPS 13 Audio crashing

Going to kind of bring this thread back from the dead a bit. I experienced the issues a few more times again but couldn't find anything setting wise that would cause my audio to just stop working.

I have no idea when the audio decides to stop working, as far as I can tell the audio stops working at random. Sometimes my laptop goes for days with zero audio problems, sometimes I experience my audio dying more than once a day.

Also it's worth pointing out that when the audio does crash, my current session of Chrome cannot play any video files (Youtube, Twitter video, etc), I get an error. That's when I know for sure that my audio has stopped working system wide. When I restart Chrome, videos play fine but of course with no audio.

To get audio back the only solution is a system restart.

Epidem
1 Nickel

Re: Dell XPS 13 Audio crashing

I reported this problem to Dell 3 or 4 months ago. Graphics card can't handle activity, often overheats system, memory runs out when playing Chrome, system freezes. Audio isn't heard. Currently I can't play Youtube videos without playing an audio somewhere else. For example, if audio won't play on yotube, I'll run amazon and then you can hear it on youtube. Or I'll go to the speaker/headphone audio slider and run it back and forth a few times and then there's a beep and it works.

drbsk
1 Copper

Re: Dell XPS 13 Audio crashing

I am having this same issue. 

0 Kudos
ChrisTM
1 Nickel

Re: Dell XPS 13 Audio crashing

Also  the exact same issue on brand new XPS 15 9575.  Only thing that gets it working again is rebooting.  Drivers up to date.  Diagnostics does nothing.

Carlos-Csharp
1 Copper

Re: Dell XPS 13 Audio crashing

I am experiencing the same symptoms described here.

Brand-new XPS 13 9370 rose-gold, 16GB RAM, 256GB ssd, i5-8250U, 1080p

All drivers are up to date and version numbers match dell.com

Sometimes after waking up from sleep, audio does not work from any application, video playback is lost (chrome, MS edge, etc.)

Only fix is to restart laptop.

This is clearly an issue reproducible by many users.

I will run diagnostics next time the issue arises and post my finds here.

This is the second XPS i'm buying in 2 years (9350 and 9370) and I hope these issues get resolved, otherwise I will refrain from using or recommending dell products.