XPS

2 Bronze

XPS 13-9370, battery drain while asleep

Hello,

My new XPS 13-9370 drains battery when it is on sleep very quickly, typically from 100% to <5% in 2 days or less (with no use). I've turned off connectivity whilst asleep, which helped but it's still far worse than I've seen from any other laptop. I've seen other posts like this elsewhere on the internet, but no good solutions. Dell, please can you advise? This seems somewhat systematic.

Thank you!

Labels (2)
Replies (6)
Community Manager
Community Manager

You said, "My new XPS 13-9370"? Based on the service tag you provided, this XPS 13-9370 shipped from Dell on 11/30/2018, so it is 7 months old.

 

Why would you keep the XPS 13-9370 in sleep on battery mode only for that long? It would be better to simply attach the 45w USB Type-C power adapter to the XPS 13-9370 left side Primary Thunderbolt 3/USB Type-C power port, then allow the XPS 13-9370 to enter sleep.

arrogant and useless comment. Why would a 2000 dollar laptop need to be constantly plugged in? May as well buy a PC. 

5 Rhenium

The 9370 is a modern standby system.  Such a system, if allowed to stay in low power mode can drain 2-4% of the battery per hour.

The way to stop that drain is to set it to go into hibernation after a period of time, such as an hour or two. 

We had a poster in another thread who stated his system would not go into hibernation and it took a Bios update to stop the drain.  You could always try that but he may have had another problem which was keeping his system from behaving correctly.

Modern Standby systems, do not "Sleep" as you would normally understand it.

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
System fully Win 11 compliant

Thank you for this helpful reply, Saltgrass. I'll try this out.

As a power XPS user, the suggestions posted by others on this thread is ridiculous.  Why would anyone put a XPS for sleep for 2 days or more? Easy - because sleep mode historically has meant minimal battery drain (less than 1% per day) while PC is on battery power.

Why would anyone keep the XPS constantly plugged in, when the constant power charge to the built-in battery will vastly shorten the battery life over time?  This is especially annoying when considering ultrabooks like the XPS makes it difficult to open and replace components like battery and other components (some of which are now soldered in and impossible to replace).


So the suggestion to keep the XPS always plugged in, is terrible and should be avoided.


Secondly, using hibernation in modern devices with SSDs like the XPS is also dangerous.  The constant writing of large amounts of RAM to the SSD will kill the SSD quickly over time.  It is unnecessary.

 

Windows / Dell need to respect users who want to put the PC to sleep and have minimal drain.  I am not using the XPS like my smartphone or tablets which use the efficient ARM CPUs that have true minimal drain while sleeping.  Don't force Intel based PCs like the XPS to behave like those devices...it's ridiculous that it would be designed this way.

 

Here are some steps to try to resolve this issue:

 

1. disabled the Connected Standby setting via registry (Regedit, Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power , make sure CSEnabled is set to "0)' or off).

2. the previous step may not be enough with the XPS.  Go to "Power & Sleep", and ensure Network Connection, Network Connection, is set to "ALWAYS".

Hopefully these steps will resolve this issue, because Microsoft Windows 10 is terrible in this regard and Dell doesn't seem to be able to help users with this fundamental issue.

Welcome to the Dell Community  @XPS-power-user 

"So the suggestion to keep the XPS always plugged in, is terrible and should be avoided."

With the advent of "SMART" power systems the battery is not constantly being charged when plugged in all the time.

The XPS 13-9370 has a "52 WHr "SMART" lithium-ion" battery.

That means it will stop charging when it reaches 100% or what every you set in "Power Management"

Most recommend to set stop at 80% and start at 20%. "Aids in extending battery life"

The default is "Adaptive"

Best regards,

U2

Top Contributor
Latest Solutions