XPS

2 Bronze

XPS 13 9380 - External Monitor Issue

I'm having a strange issue when connecting my laptop to an external monitor. I've been searching online support forums for a few days now, and have not come across exactly the same issue, though it seems like external monitor issues are common with newer xps models.

Essentially the issue I'm having is that the laptop shuts down and becomes completely unresponsive if I leave the monitor plugged in for an extended period while not using the computer. While in use, the monitor works completely without issue, so I didn't even realize there was a problem at first. This only happens when the laptop is idle and the monitor is connected while I'm away from the computer for some time. At first it seemed to be happening sporadically, but now it happens basically every time I leave for more than a few minutes. The only way to get the computer running again afterwards is to do a hard reset (pressing power button for 15-20 seconds).

I'm using a BenQ GW2480 monitor, connected via an HDMI to USB-C cable. Bios and graphics drivers are both up to date. The same thing happens whether the computer is running on battery or connected to power, and my power options are set so that the laptop never goes to sleep when plugged in. Indeed, when no monitor is connected, the laptop does not go to sleep when connected to power.

Any ideas what could be going on here?

 

Thanks!

Labels (2)
Solution (1)

Accepted Solutions

So I did this + updated graphic drivers to 27th of April from Intel (manul install, update drivers, point to .inf file). 

AND! I've switched my external monitor (USB C => HDMI) to the charging port (left side, top most usb c port), charging (i know, slowly) via 2nd usb c port. 

So far: sleep works, wake up from sleep, lock screen. No issues so far. 

 

View solution in original post

Community Accepted Solution
Replies (24)
7 Thorium

Check your Power Options, Advanced Power Settings to see if hibernation is selected. Change the setting for Hybrid Sleep and Hibernation there.That requires a brief press of the power (don't hold it down) to wake a hibernating computer. It looks like the computer is completely off and it takes a little longer to reboot but all windows will reappear on the Desktop. Hibernation is the default option that you can disable in your Power Plan. It automatically starts when the computer is idle for a long period of time. So if a mouse or KB doesn't wake the computer from Sleep, try the brief press of power button to wake it from Hibernation.

Thanks Mary G.

Just checked advanced settings and both sleep and hibernate are set to "never" when plugged in, so the computer should not be going into hibernation mode.

Also, when the problem has occurred in the past, I've tried all sorts of power button presses (short press, 5 second, 10 seconds, keyboard, mouse) and the only way to get the computer back is a really long button press of around 20 seconds.

Since this only happens when the monitor is connected, do you think the problem could be related to the USB/thunderbolt driver?

@the_woodsman  in addition to my reply above, once again if you're open to trying another cable, there's also this option.  That cable is USB-C to DisplayPort but also allows you to plug a USB-C power source into the cable, in which case you end up with a single cable to connect to your laptop that will handle both video and power.  Admittedly not essential on the XPS 13 9380 since you have multiple USB-C ports built into the system, but if you currently only connect a display cable and a power cable (as opposed to also having external USB devices), then this cable would give you the convenience of single cable connectivity without the cost of a docking station.


Thanks for the suggestion @jphughan 

I've ordered a displayport cable and will check in again once I've given it a try.

Ok, I've been using the displayport cable for a day now and the problem has not come up since. Thanks again for you help.

I'm sorry, I spoke too soon. Just now I encountered exactly the same problem using the displayport cable.

@jphughan do you have any other ideas what the source of the problem could be?

@the_woodsman  sorry to hear that.  A hard system lock that requires a forced shutdown is highly unusual behavior, so the possible culprits at this point would seem to be drivers, firmware, the display, a hardware issue with your specific unit, or something going on within Windows specific to your setup.

Normally I'd guess the first two, but given how popular the XPS 13 models are and the fact that the 9380 has been around for a while, I would expect to see more reports of this behavior by now even if this was some problem only recently introduced with a new update.  I don't really see how the display could be causing a hard system lock, but it might be the easiest of these variables to manipulate.  Do you happen to have access to another display that you'd be able to use for a while?

A hardware issue with your specific system is possible, but I do sort of wonder if there might be something going on in your specific OS/application environment.  Unfortunately if the issue only occurs when the display is put to sleep, which doesn't ever happen in environments like the pre-boot diagnostics, there isn't an easy test for that -- and even if you did use the diagnostics environment or a Linux Live environment you'd also be changing other variables such as not having the same drivers loaded.  Properly ruling out software-level causes would basically involve performing a clean installation of Windows and just your drivers to start and then seeing if the issue occurs even there.  If not, then you'd have to install your applications one at a time to see which one creates this issue -- but if the system can apparently go a few days without exhibiting this behavior, then that process would take quite a while to perform.  You could of course capture an image backup of your current environment just in case the issue occurs right away on the clean install, in which case you could at least restore that backup to get back to where you were rather than having to manually rebuild everything for no benefit, but basically you'd either be in for a drawn out rebuild process or a quick recovery but the problem still persisting.

On the other hand, ruling out a hardware issue with your unit would require access to a completely different XPS 13 9380, which unless you happen to be in a corporate environment with an IT department that has a few of those systems around to test with wouldn't be easy either.  Sorry!


@the_woodsman I have the same issue. Did you manage to get this problem resolved?

My xps 13 9830 crashed hard the INSTANT I plugged into an external monitor using a VAVA brand USB-C hub. 

I took the computer to tech support at my university, and they replicated the problem with my hub, except that it waited to crash until we switched OFF the external monitor.  Because the external monitor worked for them when they used a HooToo hub, they recommended I get a HooToo hub, which I did.  Worked when I plugged it into the external monitor, but UNPLUGGING it caused another hard crash.  

So I'd also be thrilled if anyone anywhere knew how to fix this!!!  Dell, please look into this.

Thanks.

Top Contributor
Latest Solutions