XPS

Last reply by 06-26-2019 Solved
Start a Discussion
2 Bronze
2 Bronze
10232

XPS 13 9380, Touchpad, WiFi, input lag, fixed

Got my XPS 13 9380 for 2.3K and the amount of problems I'm having with it just makes me want to smash it against a wall.

1. The biggest frustration is the touchpad. The problem with it randomly jumping and clicking when you scroll seems to not bother Dell support at all, despite all the feedback on the web.
2. When you scroll a page, it jitters.
3. When in battery mode, every click is delayed by a second or two.
4. The wifi keeps disconnecting regularly despite the driver update.
5. The update process is very glitchy, driver download takes forever and the process is never finished. Manual search of drivers on the website is a pain.
6. The Windows notification panel sometimes tries to pop up on the left side of the screen, then quickly closes and pops up on the right as it should.
7. Dell support is totally clueless and useless.

I am returning this nonsense of a laptop and will think twice the next time I am tempted to buy a Dell product.

Solution (1)

Accepted Solutions
Community Manager
10161

Posting fixes found by above user hunch7 =

Well, I have very good news, I've managed to resolve all the issues.

1. Erratic touchpad behavior
Set Touchpad sensitivity or low
* Right-click the Start button
* Click Settings
* In the blank, enter touchpad
* Click Touchpad settings
* Change Touchpad sensitivity to Low

Setting Touchpad sensitivity to low alone did not help. What did was doing this on top: open mouse properties and set double-click speed to highest, and set the number of scrolled rolls to lowest (to 1). No random clicking while scrolling anymore, woo-hoo!

2. Wireless connection stability
* Click Windows icon
* Type killer
* Click Killer Control Center
* Click Settings
* Under System Settings, toggle Advanced Stream Detect to Off
* Click Apply Changes
-or-
* Click Windows icon
* Type killer
* Click Killer Network Manager
* Click Settings
* Remove the check from, Enable Advanced Stream Detect
* Click Apply Changes
* Retest WiFi connection

* Right-click the Start button
* Click Device Manager
* Click View
* Check Show hidden devices
* Expand Network adapters
* Right click Microsoft WiFi Direct Virtual Adapter
* Click Disable device
* Close the Device Manager, restart the PC and retest WiFi

Yes, disabling the Advanced Stream Detect in Killer setting did help. WiFi is working as it should, thank you!

3. Input lag when in battery mode
* Battery only usage will always sacrifice performance options in the background and in usage. Which is why I always use my Dell XPS and Alienware Laptops with the external AC power adapter

This laptop's most attractive feature is portability, and YES, there IS a fix: click the battery icon in the tray and select highest performance; open Dell Power Manager from the Start menu and on the Battery Information tab set the Battery setting to 'Standard' -- boom, the input lag is reduced by so much that it's nearly as low as in the AC mode!

I am now a happy 9380 user and I am definitely keeping this laptop, yay!

hunch7


Social Media Support

#IWork4Dell
Find your Service Tag

View solution in original post

Reply (1)
Community Manager
10162

Posting fixes found by above user hunch7 =

Well, I have very good news, I've managed to resolve all the issues.

1. Erratic touchpad behavior
Set Touchpad sensitivity or low
* Right-click the Start button
* Click Settings
* In the blank, enter touchpad
* Click Touchpad settings
* Change Touchpad sensitivity to Low

Setting Touchpad sensitivity to low alone did not help. What did was doing this on top: open mouse properties and set double-click speed to highest, and set the number of scrolled rolls to lowest (to 1). No random clicking while scrolling anymore, woo-hoo!

2. Wireless connection stability
* Click Windows icon
* Type killer
* Click Killer Control Center
* Click Settings
* Under System Settings, toggle Advanced Stream Detect to Off
* Click Apply Changes
-or-
* Click Windows icon
* Type killer
* Click Killer Network Manager
* Click Settings
* Remove the check from, Enable Advanced Stream Detect
* Click Apply Changes
* Retest WiFi connection

* Right-click the Start button
* Click Device Manager
* Click View
* Check Show hidden devices
* Expand Network adapters
* Right click Microsoft WiFi Direct Virtual Adapter
* Click Disable device
* Close the Device Manager, restart the PC and retest WiFi

Yes, disabling the Advanced Stream Detect in Killer setting did help. WiFi is working as it should, thank you!

3. Input lag when in battery mode
* Battery only usage will always sacrifice performance options in the background and in usage. Which is why I always use my Dell XPS and Alienware Laptops with the external AC power adapter

This laptop's most attractive feature is portability, and YES, there IS a fix: click the battery icon in the tray and select highest performance; open Dell Power Manager from the Start menu and on the Battery Information tab set the Battery setting to 'Standard' -- boom, the input lag is reduced by so much that it's nearly as low as in the AC mode!

I am now a happy 9380 user and I am definitely keeping this laptop, yay!

hunch7


Social Media Support

#IWork4Dell
Find your Service Tag

Latest Solutions
Top Contributor