XPS

Last reply by 03-04-2020 Solved
Start a Discussion
1 Copper
1 Copper

XPS 13 9380, Type C/Thunderbolt port suddenly stopped working

I've had my XPS 13 9380 for a couple of weeks now, and my top left Type C/Thunderbolt port stopped working this morning. After searching the forum, I tried installing the following updates, but so far nothing has resolved the issue:

  • Chipset_Driver_V2WY5_WN32_1.16.32.1_A01
  • ASMedia-USB-Extended-Host-Controller-Driver_XHJRN_WIN_1.16.56.1_A13_01
  • Intel-Thunderbolt-Controller-Driver_886C9_WIN_17.4.77.400_A10

This seems to be a somewhat common issue. Can someone on the Dell team please help me resolve this issue?

Reply (1)
2 Bronze
2 Bronze

Hi,

I had the same problem. None of the 3 USB Thunderbolt ports would work. I tried everything I found in the online threads but nothing worked. Guess, what was the problem? The USB adapter!!!! I am sharing my experience hoping it helps, though you might have solved your problem by now.

Community Accepted Solution
Top Contributor
Latest Solutions