XPS

2 Bronze

XPS 13-9380, acpi.sys, 25% to 50% cpu usage

I recently bought an XPS 13 9380 with i7, 16G of ram, 500G of storage.

Sometimes the fans are generating huge noises so I checked the Task Manager and found that the System process is taking around 25% to 50% of CPU Usage. I used Process Explorer to check threads in System process and found that acpi.sys is taking really huge CPU Usage. This issue may not happen right after booting up but would happen after some time. I am still not clear about what triggers this issue. I tried to do a full-disk scan using Windows Defender while no virus is found. The Operation System is Win10 Pro.

This issue is seriously affecting battery life and performance on my computer. Does anyone have any idea about how to solve this issue? Might it be caused by bugs in XPS's drivers?

Labels (2)
Solutions (2)

Accepted Solutions

I disabled the Thunderbolt Controller Power Management/Allow the computer to turn off this device to save power and it solved my CPU usage problem. 

View solution in original post

Community Accepted Solution

I had the exact same problem on my XPS 13 7390 2-in-1. Problem appeared after hibernating/plugging in and out my usb-c/displayport cable to my display.

Disabling

Device manager/System devices/Thunderbolt(TM) Controller - 15D9/Properties/Power Management/Allow the computer to turn off this device to save power

made the problem go away. At least I have not seen it in a few days now.

So great thanks to everybody who helped came up with this solution! My computer is cool and silent now!

View solution in original post

Community Accepted Solution
Replies (46)
Admin
Admin

Thank you for your message. How long have you been having this issue?

 

What is the current BIOS version installed?

 

Have you made any changes to power management or changes to BIOS?

 

Is the system connected to a docking station or is there any external device connected?

 

Do you see any events recorded in the event viewer?

 

For my reference, please click on the message tab next to your avatar– click “New Message” & search for my Dell username (Sreejith R) & send a private message with the service tag, registered name & email address.

 

 

How to locate the service tag

 

 


Dell-SreejithR
Social Media Support
#IWork4Dell

Hi! 

The problem happens just one day after I bought the machine and randomly happens afterward.

BIOS version is updated to the newest as soon as I got the machine. Power Management is set to standard, and the power plan of windows is balanced.

It is frequently connected to a dock with a Bluetooth mouse, a keyboard and an external monitor(DELL) connected. I noticed that in 60 seconds after I plugging or removing any Type-C device, the CPU Usage of System would drop to normal and soon returned to around 30%.

Thank you for reminding me to check the event viewer. I DO find a special event that seems to be highly related. My CPU usage just again raises to around 30 and there is a critical event from Kernel-Power logged by System. I suspect this is just the cause.

What should I do to fix the problem?

Thank you.

I have the exact same problem. XPS 9380, i7, 16GB and 500GB SSD. The "System" process takes 25+% CPU constantly and it happens randomly. Once it starts the only way to stop it is to restart the computer. I used Process Explorer to find out exactly what was happening and it seems that it is a thread in ACPI.sys which is causing it.

I had my laptop running off battery for a couple of hours. When I reconnected the power through the USB-C port on the right side of the computer the System process CPU usage went up to 25% and now it just stays there.

I have one USB hub connected to the upper left Thunderbolt.

I have a monitor connected to the lower left Thunderbolt.

I have the charger connected to the right USB-c.

If I disconnect anything from the USB-hub the CPU load goes down to 0% for about 15 seconds after which it will go back to 25-50% again.

The same happens if I

  • Disconnect the USB hub completely
  • Disconnect the monitor 

When the CPU is 25% and I reconnect one of the devices again the CPU load once again goes down to 0%. 15 seconds later it is back up at 25%.

I have the exact same issue. To be specific:

XPS 9380

i7-8565U, 16GB RAM, 4k touch display, 256GB SSD

It is not reproducible 100% of the time, and it appears to be triggered by a variety of system events (network connect/disconnect, power connect/disconnect, device connect/disonnect, etc.).

Once reproduced, it makes ACPI.sys take a significant amount of CPU and the system performs poorly (e.g. audio stuttering).

Once stuck in this state, the only way I found to clear it is to reboot the machine. I followed the instructions on http://expensivepaperweight.com and now use the power button to hibernate. This also fixes it for a bit.

I am on the latest BIOS (1.2.1). I have tried manually changing drivers to more recent display and networking (avaialble from Intel and Killer wifi, respecitvely). The problem remains unchanged.

This computer is basically unusable, as I have to always watch to see when ACPI breaks, then stop what I'm doing and reboot/hibernate.

 

I noticed this issue this weekend.

I bought my dell about a month ago. If it helps for looking up additional details: it was purchased from this dell account.

I noticed that the laptop was often too hot to use comfortably as a laptop and would have to move to a desk. I saw the CPU was working a lot, and assumed it was windows updates or something, and I should just wait. It went on for a long time, and I finally dug deeper and saw the System process using tons of CPU every time the laptop was overly hot. Once this starts, I have to reboot to get it back to normal.

I don't know what causes it. Sometimes it happens once a day, sometimes once every five minutes. The laptop is a 9380 that I keep plugged in to power, but use wireless internet. I have no peripherals attached, and the dell update software says my drivers and BIOS are all up to date. I have made no changes to any settings except uninstalling McAfee.

Has anyone had any luck at least making it happen less frequently so I can work uninterrupted for a while?

Happy to provide any additional logs or screenshots if needed; I would really like to see this fixed!

there don't seem to be screenshots posted yet so I'll add one

https://www.youtube.com/watch?v=UTXW0ch9rw4

This video demonstrates the problem happening in response to plugging and unplugging the power cord. Sometimes this causes the issue, sometimes it doesn't. Sometimes the problem is caused by connecting the power, sometimes it's caused by disconnecting the power. I'm not sure what determines whether it happens or not.

Power is only one way this happens. The problem also happens when the laptop is left plugged in. I don't know what triggers it in that case.

What's happening in the video:

No other programs are running; the only thing being done during the recording is inserting and removing the power cable from the laptop.

0:00-0:09 - laptop is plugged in and running normally

0:10-0:23 - laptop is unplugged. right after unplugging, 'System' takes a little CPU (6%) for a second, then returns to normal.

0:24-0:43 - laptop is plugged in. After about 25 seconds of being plugged in, 'System' process runs out of control using more and more CPU.

0:44-1:03 - 'System' process remains stuck; it will not return to normal.

1:04-1:20 - laptop is unplugged and 'System' returns to normal

1:21-1:35 - laptop is plugged in. Screen freezes for several seconds, then a few seconds later 'System' process runs out of control again.

1:36-2:02 - 'System' remains stuck

2:03-2:08 - laptop is unplugged and 'System' returns to normal.

 

No errors are generated in the Event Viewer when the problem starts and stops.

I do get kernel-power and NDIS errors in the event log when doing a hibernate (which I do to make the problem go away for a while). I get these errors from hibernation whether the System process is currently broken or not, so I don't know if it's related.

Again, power is only one way this problem is triggered. I only posted a video of the power changes causing the problem because that's the easiest way I can make it happen. It happens several times every day, even if I never plug-in/unplug the laptop

It happened again. The laptop was running on battery for 2 hours. After I attached the charger the System process started taking 12% CPU (in details view of task manager) and 40% CPU in the processes view. I guess 12% translates to 100% on one logical processor (4 core i7).

I used Windows Performance Recorder to record 30 seconds of CPU activity while this was happening and then used Windows Performance Analyzer to visualize it. Below is a screenshot of the CPU usage details. 

You can see that it is a thread in hal.dll!HalpPCIConfig that is consuming almost all the CPU. Is there a loop somewhere?

The only way to stop this is to reboot the laptop. I cant keep doing this for long. Either it is fixed or I will have to return this laptop even if I love everything else about it.

Dell-XPS13-9380-ACPI-CPU-USAGE.png

@matt b,

 

 Thank you for the video.

 

Please disable all startup items including the anti-virus & check if the issue persists.

 

Try creating a new local admin account by following this link & check if the issue is observed in the new account.

 

For my reference, please click on the message tab next to your avatar– click “New Message” & search for my Dell username (Sreejith R) & send a private message with the service tag, registered name & email address.         

 

How to locate the service tag

 

 


Dell-SreejithR
Social Media Support
#IWork4Dell

Top Contributor
Latest Solutions