Highlighted
APeMa
1 Copper

XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution

Hello,

Same issue as this one:

https://www.dell.com/community/XPS/XPS-13-9380-new-plugged-in-stops-charging-2/m-p/7340955#M31923

Charger turns off randomly and you have to unplug it from the wall to turn it back on.

My XPS 13 9380 has been updated to BIOS 1.7.0

My laptop is almost 2 months old and I've had this issue since the beginning.

When the charger is plugged in and it is off (so the laptop is not charging) *OR* when the charger is not plugged into the laptop at all, the BIOS displays the same status:

Battery primary: Health excellent

AC adapter: Not installed

What was the problem or solution in the end for the previous two users?

Thanks in advance for any assistance!

0 Kudos
1 Solution

Accepted Solutions
APeMa
1 Copper

Re: XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution

Hi,

Thanks so much for everyone's help! In the end the motherboard was replaced and the issue is now fixed.

So it seems it was a hardware issue in my case.

Thanks!

0 Kudos
8 Replies
APeMa
1 Copper

Re: XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution
Some more details, answering the questions from the previous threads: 1) What is the status of the AC adapter & Battery in BIOS when the light on the adapter goes off or when it stops charging? In the BIOS it says "AC adapter not installed" both when the light of the adapter is off and when it is not plugged in the notebook at all. 2) Does it say plugged in not charging or not detected? No, it just appears as if the charger was not connected at all, it is using the battery power and you can drain the battery completely and this won't turn the charger back on (leaving it connected while the battery continues to drain as it is not charging once the led is off). 3) Does the secondary port on the right, charge the device? It does charge the device. I haven't tested to see if the charger turns off when connected to this port as I usually have it connected to the first one (I am testing it now). 4) Does the light on the adaptor cable turn on if you unplug - plug just on the notebook ; not on the wall? No, it only turns back on if you unplug & plug it to the wall, disconnecting it from the notebook does not turn it back on.
0 Kudos
APeMa
1 Copper

Re: XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution

It seems the thread I was responding to is no longer appearing, but I was responding to this one:

https://www.dell.com/community/XPS/XPS-13-9380-new-plugged-in-stops-charging-2/m-p/7340955#M31923

Also this user has the same problem:

https://www.dell.com/community/XPS/XPS-13-9380-new-plugged-in-stops-charging/td-p/7316938

 

 

0 Kudos
APeMa
1 Copper

Re: XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution

More tests:

Capture2-d93d011e-d3a5-4bb8-a3b9-c8e4682aff39-887736479.jfif

The charger turns off both using port 2 and 3. The laptop charges correctly using either of these. 

I can't see a pattern here, the charger turns off randomly. 

When the charger is not connected to the laptop, it does not turn off (or I haven't seen this happen), so this makes me think it is a software issue, but how could the OS turn off the charger? 

Any ideas for tests welcome, thanks!

0 Kudos
Moderator
Moderator

Re: XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution

Hello,

Sorry about the issue you’re experiencing on your Dell and thanks for bringing this to our attention.

 

From the description shared it looks like an issue with the charging port, but just to be sure let’s troubleshoot further. Could you private message us the system Service Tag?  

Refer to this link to find the Service Tag: https://dell.to/2NRjrf3

0 Kudos
APeMa
1 Copper

Re: XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution

Thanks for your message! I have sent you the service tag via private message.

 

0 Kudos
SoFloRaul
1 Copper

Re: XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution

Hello APeMa,

I was having a very similar issue. I XPS 13 9380 came with Ubuntu pre-installed and after researching through the logs I found the following entry in the kern.log file:

ucsi_acpi USBC000:00: ucsi_run_command: error without status
This lead me to the following intel bug with a google search:
https://bugs.launchpad.net/intel/+bug/1758797

That bug got me to check the setting in the /boot/config-4.15.0-1050-oem file for CONFIG_TYPEC_UCSI=m, and CONFIG_UCSI_ACPI=m. After changing these setting to CONFIG_TYPEC_UCSI=y, CONFIG_UCSI_ACPI=y and rebooting the issue was resolved. 

If you need more details please let me know. I will be happy to supply them.

0 Kudos
Moderator
Moderator

Re: XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution

Hello, 

I see that the onsite service on your Dell is complete. I hope the computer works fine post repairs. Should you need any help, feel free to contact us. 

 

Since the issue has been resolved, I will close this case now. If you decide to continue at a later date, you will need to start a new thread.

0 Kudos
APeMa
1 Copper

Re: XPS 13-9380, new, plugged in, stops charging? #2

Jump to solution

Hi,

Thanks so much for everyone's help! In the end the motherboard was replaced and the issue is now fixed.

So it seems it was a hardware issue in my case.

Thanks!

0 Kudos