Last reply by 03-23-2023 Unsolved
Highly Active TopicHighly Active Topic
Start a Discussion
2 Bronze
2 Bronze

XPS 13 Plus 9320, Touchpad malfunctioning


I very recently received my new XPS 13 Plus 9320. I happily used it for about a week until one the day the haptic feedback from the touchpad suddenly began malfunctioning. It still functions mostly as a mouse (moving, scrolling, clicking), but the feedback only makes a sound and no physical feedback. All feedback intensity settings feel the same except 100% where the touchpad becomes unusable. At 100% intensity the touchpad automatically clicks about every second even when I am not touching it.

I've been in touch with Dell support and have an open ticket but nothing has helped. Restarting comp, resetting settings, reinstalling/updating drivers, restoring comp, and reinstalling windows 11 have not fixed it. Seems likely to be a hardware issue at this point.

Has anyone else experienced this? This issue makes for a poor experience using the touchpad and I am unhappy that a week-old machine would physically break without any apparent trauma.


Replies (60)
2 Bronze
2 Bronze

UPDATE - I can't speak for everyone here, but the new firmware does seem to have solved the biggest issues with the touchpad for me. It still isn't perfect and occasionally gets stuck as if it's clicked, but I haven't experienced the repetitive clicking since then.


Does not apply to Dell XPS 13 9320 Plus shipped with Ubuntu Linux OS. This is Windows only firmware release. Support for linux? 

Plus, as OP also admitted, this firmware update does not solve the problem of touchpad being stuck for seconds in the pressed position. 


This firmware doesn’t fix the problem. It sounds like one of the piezoelectric buzzers came loose from the base of the trackpad on mine. 


same issue here. 

2 Bronze
2 Bronze

Dell technician came to replace the touchpad (which consists in the whole palmrest). 

First we reset the BIOS settings (version 1.8.1) to factory default. Touchpad pressure sensors kept exhibiting random behavior. After replacing the hardware, the touchpad pressure feedback "clicks" only worked when pressing strongly at the center of the touchpad, not at the borders. Then, the technician re-opened the laptop, took off the battery and re-installed it. This time the touchpad pressure sensors were working as expected. Neither me nor the technician could tell why.

Afterwards, I rebooted and reverted the BIOS settings to Latest User Saved. This very moment touchpad pressure sensors stopped working altogether. I once again rebooted and restored the BIOS factory settings but the touchpad pressure sensors kept not working. It's been over one week they don't work at all.

Now waiting for the 2nd hardware replacement. Truly embarrassing experience for the most expensive professional laptop model on sale by Dell. With Dell, even if you don't mind money you have to mind technical problems.

2 Bronze
2 Bronze

Small update from my part: touchpad got replaced again, together with keyboard. Now i have a working touchpad AND a working fingerprint scanner! So seems i'm completely fine for now.


Hi Chris,

I would like to reach out to dell directly and not through a customer service center.

I'm an electronics engineer and have the dell xps 13 plus. My palm rest has been replaced twice. However i have a theory which might help you guys understand the issue as this forum post and the fact my mechanic needed to send the palmrest back clearly shows there is an underlying issue which you guys haven't really figured out.

Do what you want to do with this information but hopefully this helps in the investigation, maybe you guys are already on the issue and have created a new revision, but nonetheless i'm going to tell my thoughts.

I have an aftermarket charger that i plugged in as soon as i got the laptop. But after a while i noticed that my touchpad would act in an entirely different way during some moments and others would be fine. The responsiveness would just be sluggish. Through my background i got to testing and soon i figured that it was the charger that did this. I accepted it at that point and thought well maybe dell has some weird driver that acts up when a non standard charger is plugged in.

After a while i got an external powerbank that supports Power delivery. That powerbank has a small screen for providing information and the first thing it told me that that particular charger's output voltage "was too high". So something clicked there in my mind but it let it rest up untill now. Especially because my replacement palmrest was working fine until i plugged in that charger (by accident) again.

This palmrest consists of piezo electric buzzers that simulate the feel of a click. Under the touchpad there is a PCB that, presumably, contains a capacitive surface that measures if a finger touches the touchpad. 

I think this laptop is unable to deal with common mode noise that bad chargers generate. My theory is that if a charge is applied to this laptop it can damage the palmrest. Especially due to the fact that my charger changed the way the touchpad behaved when plugged in. Everytime when i removed the charger the touchpad would resume normal operation after about a minute or 2. That reinforces my theory that a capacitive load is applied to the laptop.

The natural response from a manufacturer is "don't use third party chargers" but in this day and age of USB-C, which not only applies to chargers but also docks is not really the best way to look at this issue. I hope the dell engineers have already figured this out and are working on a solution, but if not, maybe this helps.

If you guys have any questions or would like to have my charger ( as i'm not going to use that one anymore) please reach out and let me know.

Kind regards,


My Dell XPS 13 Plus 9320 was delivered yesterday (01/16/2023). This is making a rattling noise at every startup. First I thought it was a CPU fan but further internet search led me to this thread and when I literally put my ear on the touchpad during the startup, I am positive that this rattling noise that persists only for about a second at each startup is coming from this haptic touchpad. And of course I have run "Dell-Touchpad-Firmware-Update-Utility_KR08K_WIN64_2022.08.15.01_A00.EXE" to install the latest firmware update on my machine and the issue still exists. My BIOS Version is 1.9.0 (as seen directly from BIOS Setup via startup interrupt using F12).  Do you think I need a replacement touchpad? I am a bit nervous as others have reported their fingerprint reader getting messed up after this replacement.


I wish there was a BIOS Option that would disable the touchpad at startup if a USB mouse was detected!


Regards - JNP!

2 Bronze
2 Bronze

Just to add another unhappy customer with unrelaible trackpad.  For me the "clicking" is intermittantly "sticky".  Sometimes it works fine but every so often it will be stuck in the "clicked" position meaning chaos on screen.  I use a mouse most of the time but when mobile this is a real pain.  My 2nd XPS machine after an engineer failed on several to resolve issues on my previous model, I don't want to go through all that again so this is likely to be my last Dell and I'm counting the days until I can replace it.

Community Manager

I know I sent some Private Messages on this, but if anyone is still having trouble with their Touchpad please Private Message me Directly with your Service Tag. 


Also, per Dell-Chris M's post, please make sure to have updated to the latest Touchpad Firmware. 


The BIOS can also be updated at this<ADMIN NOTE: Broken link has been removed from this post by Dell>.


For users using Ubuntu 22.04 LTS,  the Touchpad Firmware can be updated at this link.

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag

Latest Solutions
Top Contributor