XPS

Last reply by 07-01-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
104

XPS 13 Plus will not go beyond 1080p on ONE of my external displays

Just got my new XPS 13 but I have the weirdest issue that I cannot resolve, and am trying to avoid returning the laptop to dell for a refund. 

 

I have two external displays. Both 4k. One is an LG c2 oled, and the other a gigabyte m32u. 

The gigabyte m32u which has a dedicated type-c input works fine. 4k and 144hz. 

but the dell refuses to output more than 1080p to the LG tv, no matter what I do. 

I'm using an 8k capable type-c to HDMI 2.1 adapter (in fact, I've tried two). 

Both of the adapters I've tried will work no issue with other devices. So my macbook for example does 4k no problem via the same adapter. 

But the dell, not matter what I do, will not output more than 1080p. 

Weirdly, the intel graphics control panel is detecting the LG TV. Reports it's capable of 4k. displays the correct edid data showing 4k 120hz as a supported resolution, but the control panel still tops out at 1080p. 

I've tried adding 3840x2160 as a custom resolution, and it even seems to think it's working. It lets me select it, and doesn't show any errors. But i'm still in 1080p. 

I use the LG TV as a monitor for my work, and so if I can't fix this issue, I'll need to send the laptop back to dell. 

Does anyone have any potential solutions?

Reply (1)
2 Bronze
2 Bronze
94

I've narrowed it down to being a driver issue, but i'm unable to resolve it so I think I need to send it back. 

I tried resintalling the video driver. It failed, but then suddenly starting working and offered 4k resolution. 

But after a reboot, it was back to being stuck at 1080p, and ever attempt to reinstall the video driver since then has worked normally, but not fixed the issue.

Bizarre, but I can't solve it and I don't expect dell customer service to be smart enough or wiling to take the time to resolve the issue. 

Latest Solutions
Top Contributor