Highlighted

XPS 13 keyboard doesn't detect simulataneous keypresses reliably (all models)

I've got a problem with all XPS 13 models I've tested, and that's the 9350 (which I own), the 2017 model and the brand new 9370 model.

When I press multiple keys at exactly the same time, in about 10-20% of cases only one of the two keypresses is detected. Simple test: open a text editor and try to press keys A and S at the same time. Watch closely what appears on screen. Most of the time, you'll see "as" or "sa". But sometimes you'll see only "a" or "s".

You might ask: why is this important for the XPS 13 (it is no gaming machine). The problem is it can be any two keys, including modifier keys. In my case, as a power user I often use keyboard shortcuts with two modifier keys, such as Ctrl-Shift-F for formatting code in my IDE. My 30+ years of muscle memory is trained to press all modifier keys at the same time, then press the non-modifier key. On the XPS 13, this often leads to uppercase F letters (Shift-F) inserted into my source code or another shortcut being invoked (Ctrl-F = Find).

The issue is independent of the operating system. I tested the preinstalled Windows, the preinstalled Ubuntu (on the developer edition), and updated Ubuntu (16.04) and I think also keyboard input in the BIOS itself. The XPS 15 line doesn't seem to exhibit this problem, at least I could not reproduce the problem on a 2016-ish XPS 15.

So Dell, pretty please, can you fix this keyboard issue and hopefully release the fix as a BIOS upgrade also for the older models? Most likely, you had it already fixed at some point on the XPS 15.

 

Labels (3)
8 Replies
Moderator
Moderator

Re: XPS 13 keyboard doesn't detect simulataneous keypresses reliably (all models)

Heavenly Melancholy,

Thank you for this information. I will pass it along to our engineering department to see if they can get it resolved.

Social Media Support
#IWork4Dell
To help us troubleshoot, send us via a private message: Dell PC or Monitor Service Tag number
Out of Warranty Support
Where do I find my Dell PC Service Tag or Express service code?
Where do I post SA (SupportAssist) issue/questions?
0 Kudos
CalmDownMonkey
1 Nickel

Re: XPS 13 keyboard doesn't detect simulataneous keypresses reliably (all models)

Wow that's infuriating... I see you can replicate the issue here quite easily:

http://keyboardchecker.com/

Keep pressing Ctrl+Shift together and you'll see eventually, only one of the two keys is pressed.

hope this is related to the other keyboard issue:

https://www.dell.com/community/XPS/XPS-13-9370-Keyboard-Skips-Button-Presses/td-p/5835431

Is anyone from Dell able to give us assurances that this can be fixed in a BIOS update, and that it isn't a hardware flaw? I'd hate to hold on to this machine beyond my return cut-off only to find it isn't fixable. Thanks!

Re: XPS 13 keyboard doesn't detect simulataneous keypresses reliably (all models)

Oh, indeed, the keyboard checker makes it much easier to detect!

I'm not sure if the other issue mentioned is related to this issue, because I cannot reproduce the other issue on my 9350.

0 Kudos
Tree Beard
1 Copper

Re: XPS 13 keyboard doesn't detect simulataneous keypresses reliably (all models)

I'm experiencing the exact same thing on my new XPS13 9370.

I often press Ctrl-Alt-arrow to change desktops and about 20% of the time it only registers as either Ctrl or Alt pushed.

0 Kudos

Re: XPS 13 keyboard doesn't detect simulataneous keypresses reliably (all models)

Jesse, is there any news to this issue? I'm really interested in possible fixes or workarounds.

0 Kudos

Re: XPS 13 keyboard doesn't detect simulataneous keypresses

Jesse?

0 Kudos

Re: XPS 13 keyboard doesn't detect simulataneous keypresses

This is still an issue.

0 Kudos

Re: XPS 13 keyboard doesn't detect simulataneous keypresses

Jesse, this is still an issue. What's the resolution offered by Dell?

0 Kudos