XPS

Last reply by 02-06-2023 Solved
Start a Discussion
2 Bronze
2 Bronze
22349

XPS 15 7590, Memory Integrity on causes an inaccessible boot device

XPS 15 7590

Hey all,

Just wanted to report a minor bug with a fresh install on Windows 11 22H2 on XPS 15 7590.

When trying to turn on Memory Integrity under Device Security / Core Isolation, upon next reboot i get a blue screen with Inaccessible Boot Device.

Yes, I'm using the latest Intel Chipset Drivers and XPS 15 7590 firmware.

Yes my Windows 11 is up to date.

<Your purchased 1 year warranty expired on August 2, 2020. DELL-Admin>

Replies (135)
2 Bronze
2 Bronze
1840

..the icon to update to win 22h2 reappeared...do I try to update again or am I still waiting?

2 Bronze
2 Bronze
1686

I have had this issue for months now, I have tried literally everything. I work as a software developer and I have had to go back to developing on windows instead of using wsl2. If I ever find a solution I will update here, and if anyone else does please post your solution, I will be checking regularly.

3 Argentum
1649

Hi

I too have this issue on my XPS 15 7590 when installed on a clean version of 22H2

I also have all the latest Dell and Windows Updates including the BIOS Version/Date Dell Inc. 1.19.0, 14/9/2022

I am trying to install Hyper V and also receive the inaccessible boot device message. Interestingly I’ve noticed a critical error which states

Bootmgr failed to obtain the BitLocker volume master key from the TPM

 

And that the TPM requires a Firmware Update (created a thread for this too)

I have created an easy to follow step by step instruction to recreate my issue here on Dell

https://www.dell.com/community/XPS/XPS-15-7590-cannot-install-Hyper-V-on-Windows-22H2-causes/m-p/829...

and have noticed a number of us have raised similar on the W11 Feedback Hub

I have looked at the W11 Health Dashboard here:

https://learn.microsoft.com/en-us/windows/release-health/status-windows-11-22h2

But unfortunately, I cannot see this particular issue raised in the list and can’t find any way to raise it there.

1649

also found a critical error stating

The virtualization-based security enablement policy check at phase 0 failed with status: Virtual Secure Mode (VSM) is not initialized. The hypervisor or VSM may not be present or enabled

Checking in the Bios, I have both enabled - 

Enable VT for Direct I/O          YES

Enable Intel Virtualization Technology       YES

2 Bronze
2 Bronze
1433

I'm having the same problem. Hoping for a solution. Thanks for your posting.

 

2 Bronze
2 Bronze
1415

Same issue, drivers and BIOS all up to date VT for Direct I/O  and Intel Virtualization Technology both  enabled and WSL2, laptop doesn't both after upgrade and reverts back to 21H2. 

 

 

 

 

938

I have tried everything to patch my Dell XPS 15 7590 to no avail.

905

I have all drivers and Bios updated. Tried to update to 22h2 after the update icon in Win Update reappeared, same error. Download and then revert to 21h2. Done all the Microsoft tests and the laptop is eligible for the update. What should I do?

2 Bronze
2 Bronze
847

I am starting to get the inaccessible boot device error even if core isolation is turned off upon restart. It is unacceptable that this is taking so long. Microsoft doesn't seem to be doing anything about this and it's happening with many who own a Dell XPS 7590.

2 Jasper
2 Jasper
1096

Latest Solutions
Top Contributor