Highlighted

XPS 15 7590 headphone echo

When using headphones on my XPS 15 7590 with either the WD19TB dock or the headphone jack on the laptop itself I'm finding there's an echo. It's most noticeable on voices on things like Disney+ and Netflix.

I've found lots of posts on the net talking about similar issues, but I can't find one which seems to make a difference to me.

If I disable the MaxxAudio settings then it's as if I can only hear the "surround sound" speakers (i.e. voice disappears almost entirely).

Any suggestions?

3 Replies
Highlighted
1 Copper

Re: XPS 15 7590 headphone echo

I am experiencing the same problem both with the in-built speakers and headphone especially on voice.

This makes editing really frustrating. 

Any solutions to this pls? 

0 Kudos
Highlighted
1 Copper

Re: XPS 15 7590 headphone echo

In order to fix this issue I went ahead and opened the Volume Mixer by right clicking on the Volume icon in the task bar. Then in the volume mixer, I clicked on the headphone icon to open Headphone Properties. There I went to the Advanced tab. Under Special Enhancements I found that the "Enable audio enhancements" box was checked. Once I unchecked it the echo went away. Hope this helps!

Highlighted
1 Copper

Re: XPS 15 7590 headphone echo

@Afernandez290  Thank you thank you thank you! This was driving me nuts, and this completely fixed it!

0 Kudos