Last reply by 12-22-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 7590 no longer charges through USBC

XPS 15 7590

My laptop recently stopped charging via USB C. Is there a way for me to determine if this is a hardware problem or software problem? If it is a hardware problem, is there a way to disable the USB C charging so that I can continue to dock my xps but have it charge via the AC Adapter?

Some background:

My dock is a WD19TB.

I have tried charging via USB C using my dock, a USB C charger, and several Dell USBC docking stations that are at work.

I can charge via the AC Adapter, but not via the AC adapter while the laptop is hooked up to a dock (have tried both mine and the dock at work).

According to dell.com/support, my drivers are up to date. "Your system is up to date" it says in a green banner. However, if I scroll down a bit, there are a bunch of critical and recommended updates available. I don't know what those are since it says my system is up to date. Should I install those? I've also run Dell Update, a program that I have installed on my computer and it says, "This system is up to date".

I'm on windows 11 Home version 22H2.

I'm out of warranty.

Any suggestions? Thanks in advance.

Replies (0)
Latest Solutions
Top Contributor