XPS

Last reply by 04-17-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 9500 (2020) - AC adapter not recognised post My Dell Support update

Hi All

Very concerning issue.

Just did a My Dell > Support Driver Update and a Windows Update to Windows 10 Pro 19042.685

The Dell Support did two activities

  • Realtek Audio Driver Update - A07 (598.21MB)
  • SupportAssist OS Recovery (180MB)

I immediately noticed that the Audio Stopped working properly and instead of playing the audio, I would hear a hissing noise - volume rocking up / down using the Windows slider just made the audio hissing louder or softer

 

I then used Windows Device Manager to rollback the driver and immediately after a restart the audio was back !

 

Then after a few hours of use, Windows advises that it was low on battery. Connected the cable (light on cable) from supplied charger but it wouldn’t charge.

Instead windows advises : “Cable plugged in but not charging”

The front LED indicator does not turn on either.

Tried to update the AC adapter driver in Device Manager - but no new drivers and no driver to rollback to.

I restart the PC, plug in the cable  - same message

PC battery just drained to 3% when I did a shutdown.

Laptop was fine until I did the DELL update today and things started failing one after the other.

My Dell XPS 15 9500 (2020) is just a very expensive metal brick.

 

Replies (75)

Hi Guys

Replying to my own message to update:

I posted poorly as I am new to this.

I have a Dell XPS 15 9500 2020 (Small form factor 15".

What I meant to say after my fix suggestion was:

When its charging and you SWITCH to battery - when you plug back in you often lose the charging capability and you are back to stage 1.

Hardware or software - its such a pain that I wont be spending so much on a Dell ever again. Always avoided preferring HP Spectre X360 15 and previously Lenovo Yoga 3.

Hey Ho.

Good luck all

FYI @thementalist + @AnotherDellBrick  + @Mz9999 + @mae__stro 

 

I'm having the exact same problem as you with my XPS 15 9500. I think it is weirdo though, because I don't have the Windows 10 update 20H2. I'll head your advice though and change my settings accordingly. So do I make it so that folding my laptop turns it off or does nothing?

Moderator
Moderator

Regarding the AC adapter not recognized concern,
Could you share images of the adapter, power cord, charging pin, and charging port via private note? This is to check if these parts are intact.

 

Kavyashree


Social Media Support

#IWork4Dell
Find your Service Tag

@DELL-Cares  May I point out that the 9500 does not have a charging point, and the charger does not have a charging pin.  Perhaps you would be more helpful if you looked up the model before asking for information that doesn't exist?

Can you diagnose a USB-C port by a photo of the connector - interesting skill.

Hello,

 

Just wanted to add, that I have the exact same problem.

Only a shutdown (not reboot) and reconnecting the USB-C charger will work.

This started end of 2020 - I have since then installed every Dell driver so my 9500 is up to date

This is so annoying! Please help

I have this problem too!

For anyone following this:

After trying to solve the problem by updating all system drivers to the most recent versions, I have restored all of the initial drivers using offical Dell software and so far was unable to reproduce the problem, which means that the charging works fine in every scenario now.

  1. Download and install the Dell Command | Update application, version January 29 2021 (https://dl.dell.com/FOLDER06986472M/1/Dell-Command-Update-Application-for-Windows-10_DF2DT_WIN_4.1.0...)
  2. Go to settings (cog wheel symbol)
  3. Choose advanced driver restore, activate the slider and make sure you select to download the package
  4. Install / Restore the drivers including reboot
  5. Power off the laptop
  6. Power on the laptop

 

Afterwards the Dell Command | Update application will check for more recent update, but I have not installed these yet.

My charger has been working for several hours now without the problem. I deliberately unplugged the charger, close the laptop lid to initiate hibernate etc., which previously resulted in the problem sometimes. I am going to observe the behaviour the next day(s) to post an update.

 

Update:

After 30 hours of operating normally, the problem occurred again, unfortunately.

So the restore of drivers did something, but nothing persisting. 

Dell technician is scheduled to replace the motherboard today.

Hello,

The service booked to replace the motherboard was canceled after you confirmed the issue has been fixed. We'll have to rebook the service now. Could you private message us and confirm if we could use the same details as for the previous service?  


Dell-SimranC
Social Media Support
#IWork4Dell

Hello Dell-SimranC,

I cannot access my private messages anymore nor start a new message thread.

"You do not have sufficient privileges for this resource or its parent to perform this action.

Click your browser's Back button to continue."

The letter icon is missing from my profile, too.

Looks like I am locked out of this functionality.

 

However, the technician just called me and confirmed the appointment today. He is to arrive within the next few hours.

I never reported the problem being fixed, I only wanted to observe the behavior after the driver restore for a longer period of time, since I noticed that the problem has not occurred for a while, when it usually did.

 

 

Top Contributor
Latest Solutions