Last reply by 10-06-2022 Unsolved
Start a Discussion
3 Silver

XPS 15 9500 4k Video Playback Problems

I have the Dell XPS 15 9500 4k and have been having issues with streaming 4k video.

Basic spec:
9500 4k Touch Screen
Intel 10750H
1650 TI

The Problem:
The laptop is now unable to stream 4k from Netflix/Disney Plus. 4k YouTube video very jerky and unwatchable.

I want to see if anyone else has this problem and go over what Dell has done so far. This is our 4th XPS 15 Laptop we bought for work (this is the only 4k model though). Really like them so this isn’t a “slag off Dell” post. Just wanted to write up where I am with it. Sorry for the long post.

When new (bought in late 2021), this laptop played Netflix 4k films fine using the Netflix app. When you go into Netflix and select a film (say 6 Underground), the info shows its Dolby Vision - Atmos. It played the film in full 4k, HDR etc. This can be checked by pressing CTR, SHIFT, ALT, Q when the film is running to pull up the nerd info from Netflix. Here it shows it’s running in 4k etc. Disney Plus app also worked fine in 4k.

Using Edge browser to open Youtube and run a 4k 60 FPS video was also fine. Stats for nerds showed no dropped frames here, great video smooth playback.

A couple of months on I’m not able to play 4k films in the Netflix app, get Netflix Error U7361-1255-8004CD22. Select the film and the info shows its Dolby Vision – Atmos so it should be able to run in 4k but won’t.

YouTube will play the same 4k 60 FPS video but it's jerky and unwatchable, stats for nerds show its dropping frames constantly.

The only thing that’s changed on the laptop is updating the windows updates and the Dell driver updates. As of writing, ALL bios, driver, windows updates are done.

The Intel Graphics Command Centre says the display is NOT HDCP compatible.

I’ve spoken to Dell, they confirmed the machine is HDCP 2.2 complaint. They thought the motherboard was faulty so sent a tech round to replace it. We replaced the mobo and put in the same Hard Drive and booted it up. Netflix was now able to run a 4k film, but it was jerky, out of sync with the sound and basically unwatchable. YouTube 4k test video was just as bad as it was before. The Intel Graphics Command Centre still says the display is not HDCP compatible.

The Dell Support software found a new bios update for the motherboard, so we flash the bios and install it. Reboot the laptop and now Netflix and Disney Plus won’t play the 4k movies. They throw up the same error codes that mean there’s a problem with HDCP (Disney Plus is error code 39 I think)

I decided to do a full Windows restore and wipe the computer and reinstall windows 11. Fresh install with all the relevant updates and the same problems. Same error codes on Netflix and Disney Plus. Same problem on Youtube 4k video playback.

Dell has offered to replace the laptop but as the 9500 is no longer made, they offered the newer 9510. The problem is they don’t have the 4k screen model so was only able to offer the basic entry model. Whilst I appreciate this, I do need the 4k so as of now I’m waiting for that to become available but it's looking like it will be months before a replacement is offered.

I would be happy to keep my current laptop if there was a way to fix it but as of now, we can't seem to do that.

Does anyone else have this issue or do just have a faulty laptop that needs replacing?

Replies (117)

Assuming the laptop is the 4k UHD version, what is the error code that comes up from Netflix? Does it only come up when you try and play a 4k movie?

2 Bronze
2 Bronze


I also encountered the same usage problems as you. My model is XPS 15 9500 with a 4K touch screen. Since December last year, I have continuously used Windows10's Netflix app to watch videos. I can play 4K and HDR, but sometimes it comes out the current frame problem (should be due to the APP). At that time, the main viewing channel was still on TV or APPLE TV, but after I started working in other places in May this year, I began to focus on watching Netflix with XPS. The intermediate system and drivers were upgraded normally, but Netflix and Disney+ can't play 4K anymore.

According to Netflix's problem code, I consulted Netflix customer service. The main problem is on HDCP, which should be a system and driver problem, but I have not encountered it in the past. Later, I tried to find that in the display card option, I forced the graphics card accelerator of the APP into a discrete graphics card to play normally, but only It can decode AVC by default, so there is no 4K or HDR.

Weirdly, the movie and TV apps that come with the system can play 4K HDR resources normally and light up Dolby Vision icons, but streaming apps such as Netflix don't work, even on Edge. After contacting Dell after-sales service and many attempts, including replacing the driver, updating the system, resetting the system and other methods, the problem remains.

Therefore, I suspect that DELL's updated BIOS has caused the failure of the inspection mechanism of this kind of streaming media APP, which cannot effectively recognize the HDR authentication of the display screen. According to Dell's official promotion, this screen of XPS is certified by Dolby Vision, but from the advanced display settings of the system, the HDR of the built-in screen is uncertified.

Since there is no way to return to the early BIOS version, I can't confirm my conjecture, but I also hope that Dell can find a solution as soon as possible.

3 Silver

Hi Fangyoung.
From what you described, you have the same laptop with exactly the same problem as I did. I still believe this is something to do with Intel and Dell has finally replicated this problem and sent it across to Intel to work on. They say they will have a solution to this problem towards the end of this year. Dell actually sent me a link to a page that will let you load an older bios version of the laptop, I did try this, but it didn’t work, but more importantly it would mean opening up the laptop to security vulnerabilities that come with an older bios version so this was never going to be a viable fix.

I would think your options would be to either wait (and hope) that Dell will find a solution to this fault and release an update that would fix it, or if the laptop is still within warranty, you could press them for a full refund as I did.

I would expect that it will be quite a fight with Dell if you go down the refund route but if the laptop is still within warranty, then technically this is a fault (as the laptop was sold being able to play 4k, it’s HDCP 2.2 compatible etc).

I can say that the newer model (XPS 15 9520 4k i7) does seem to work with Netflix and Disney plus. It also runs YouTube 4k without being jerky and dropping frames. Whilst the Intel Graphics Command Centre software still says the screen is NOT HDCP compatible (click Display, then information to see this in this software) it still runs Netflix in full 4k Resolution, Dolby Vision etc. 

2 Bronze
2 Bronze

I still have the basic 3 year warranty with ADP and there is no resolution to this issue. They just waste your time trying things that don’t resolve it for the XPS 9500 4K. I’d be surprised if they have anything for the other models now apparently affected. 

2 Bronze
2 Bronze

Same problem here.  Netflix does not work with 4K either with their app or Edge.  The display is listed as non compliant for HDCP.

This is on a XPS 17 9700.

I have full support.  Will contact them and expect a bios update or refund.

End of story.



This seems to be a more common theme now with the slightly older XPS range. I thought it was just my laptop that was faulty but this thread proves that there are many other people with this problem. I’m now sure it wasn’t a fault with my individual laptop, rather it’s a design fault that Dell is now beginning to realise is becoming an issue as customers get angry about being sold a laptop that can’t do what it was sold to do.

I can confirm the XPS 15 4k screen is HDCP 2.2 compatible (even though the Intel Graphics Command Centre says it’s not), I would assume the 17-inch is as well, or Dell advertises and sell them as being HDCP compatible anyway.

I can confirm I have (today) received my full refund on the laptop after sending it back to them. I had to fight for this and I expect if you go down this route, Dell with try and stall and frustrate this process as much as possible with “technical help”.

To be fair to Dell, they have now told me (although getting this information out of them was excruciating painful) that they have replicated the problem my laptop had and sent it back to Intel for them to work on. They thought that a solution would be available towards the end of this year, but this was just a guess on timescales.


How do we give you this information?


2 Bronze
2 Bronze

Just jumping in here to say that I have the exact same issue with a Lenovo ThinkPad P1. Which obviously suggests that the issue is not specific to Dell. I'll be happy to provide as many details as I can if you think it can help you figure this out.


Which processor and GPU does your P1 have. Also 10th gen?


Yes, i7-10850H CPU @ 2.70GHz. So should be 10th gen. Intel UHD Graphics.

Latest Solutions
Top Contributor