Last reply by 11-19-2022 Solved
Start a Discussion
3 Silver

XPS 15 9500 4k Video Playback Problems

I have the Dell XPS 15 9500 4k and have been having issues with streaming 4k video.

Basic spec:
9500 4k Touch Screen
Intel 10750H
1650 TI

The Problem:
The laptop is now unable to stream 4k from Netflix/Disney Plus. 4k YouTube video very jerky and unwatchable.

I want to see if anyone else has this problem and go over what Dell has done so far. This is our 4th XPS 15 Laptop we bought for work (this is the only 4k model though). Really like them so this isn’t a “slag off Dell” post. Just wanted to write up where I am with it. Sorry for the long post.

When new (bought in late 2021), this laptop played Netflix 4k films fine using the Netflix app. When you go into Netflix and select a film (say 6 Underground), the info shows its Dolby Vision - Atmos. It played the film in full 4k, HDR etc. This can be checked by pressing CTR, SHIFT, ALT, Q when the film is running to pull up the nerd info from Netflix. Here it shows it’s running in 4k etc. Disney Plus app also worked fine in 4k.

Using Edge browser to open Youtube and run a 4k 60 FPS video was also fine. Stats for nerds showed no dropped frames here, great video smooth playback.

A couple of months on I’m not able to play 4k films in the Netflix app, get Netflix Error U7361-1255-8004CD22. Select the film and the info shows its Dolby Vision – Atmos so it should be able to run in 4k but won’t.

YouTube will play the same 4k 60 FPS video but it's jerky and unwatchable, stats for nerds show its dropping frames constantly.

The only thing that’s changed on the laptop is updating the windows updates and the Dell driver updates. As of writing, ALL bios, driver, windows updates are done.

The Intel Graphics Command Centre says the display is NOT HDCP compatible.

I’ve spoken to Dell, they confirmed the machine is HDCP 2.2 complaint. They thought the motherboard was faulty so sent a tech round to replace it. We replaced the mobo and put in the same Hard Drive and booted it up. Netflix was now able to run a 4k film, but it was jerky, out of sync with the sound and basically unwatchable. YouTube 4k test video was just as bad as it was before. The Intel Graphics Command Centre still says the display is not HDCP compatible.

The Dell Support software found a new bios update for the motherboard, so we flash the bios and install it. Reboot the laptop and now Netflix and Disney Plus won’t play the 4k movies. They throw up the same error codes that mean there’s a problem with HDCP (Disney Plus is error code 39 I think)

I decided to do a full Windows restore and wipe the computer and reinstall windows 11. Fresh install with all the relevant updates and the same problems. Same error codes on Netflix and Disney Plus. Same problem on Youtube 4k video playback.

Dell has offered to replace the laptop but as the 9500 is no longer made, they offered the newer 9510. The problem is they don’t have the 4k screen model so was only able to offer the basic entry model. Whilst I appreciate this, I do need the 4k so as of now I’m waiting for that to become available but it's looking like it will be months before a replacement is offered.

I would be happy to keep my current laptop if there was a way to fix it but as of now, we can't seem to do that.

Does anyone else have this issue or do just have a faulty laptop that needs replacing?

Replies (139)

This is what I was last told by Dell, let's hope they actually do what they say they are going to do and it's not just more hot air being spouted. 
In other news, (after I got my full refund for the faulty laptop and spent the additional £1000 odd pounds to buy the newer model to resolve this issue), Dell kindly sent me a £50 voucher so someone up there must have actually felt a tiny bit of guilt..... But I doubt it....

3 Silver

In trying to escape Dell and their software bugs, I bought a new notebook with Alder Lake-P from a different manufacturer.

Sadly the integrated screen is not 4K, so the device by itself will never attempt UHD playback. And Netflix UHD playback works as expected via HDMI (with a USB-C adapter, device has no native HDMI ports. So signal is definitely going through Displayport), but it did not at all with Displayport directly, even with the same monitor (also that monitor previously supported it and was the one the 9500 could achieve UHD playback with).

I either get a new error code from Netflix or just FHD playback. 

So this is starting to look like Netflix and Intel (and maybe Microsoft) have more to do with those problems than Dell itself...

2 Bronze
2 Bronze

I've got the same issue with the Inspiron 7300 2n1 Black Edition. And the problem happened within the same time frame you described as well. DELL NEEDS TO DO SOMETHING ABOUT THIS!!!





This might be because Arcane and similar animated shows like the Cuphead Show, despite being in Dolby Vision are only in Full HD and not 4K and thus Netflix can stream them without a problem.


Attn Thread Posters:  Received information today from Dell Engineering that  a new version of BIOS is getting released by the second week of October. 


If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag


I think you are a bunch of liars. I have received several emails from supervisors as well as phone calls saying a new bios will be released first week of September,. Version 1.18.0.

Well I decided to check it out today and guess what 1.18.0 was already released August 8th. So all those emails are a bunch of lies.

I now have to wait another friggin month? The. What? It still doesn't work? A flagship 9700 that can't play Netflix movies is completely unacceptable. I want a refund. I have full support costing somewhere around 400 dlars and this is worse than a kick in the you know where.





Refund my money. I'll go with HP or Microsoft.

2o years of dell computers and this has no priority.

You got my coordinates, arrange to pick it up and refund all including my support costs Enough is enough.


2 Bronze
2 Bronze

Well haven't heard anything yet?

Perhaps all these dell users with 4k monitors would join a<Legalistic statement removed.TOS73>.

Already joined one against defective retina displays with Apple and we all got our money back. I'm sure Dell would enjoy that.

2 Bronze
2 Bronze

Hi all,

Unfortunately I have the exact same issue with my Dell XPS 9700 4K. It started somewhere around march this year. I wonder if this problem ever get fixed...


I would expect the 9700 and the 9500 (17-inch and 15-inch) laptops to get fixed at the same time. If we wait until the second week of October, we should see a Bios update get released, or that's what Dell has claimed anyway. I would like to think that due to the number of people that have this issue, Dell has bumped up the priority of finding a solution to this and taken the task away from the printer repair guy and with a bit of luck, given the task to someone what can turn a computer on. To be fair to Dell, they have only been aware of this issue now for a good 10 months so let’s not get too excited.

Many owners have been told different things when speaking to Dell support. I would advise completely ignoring Dell's first line of support when it comes to this issue as these guys have about as much technical skill and knowledge as your local mobile phone kiosk operator. They tend to be reading from a script and it seems Dell hasn’t informed these guys this is now a common and known issue, so these guys will attempt to fix it for you with helpful suggestions such as “have you tried turning it off and on again”.

Let's wait until October and see if Dell release this bios update that will then allow these laptops to actually do what they claimed they could do when we bought them.

Latest Solutions
Top Contributor