Last reply by 11-19-2022 Solved
Start a Discussion
3 Silver

XPS 15 9500 4k Video Playback Problems

I have the Dell XPS 15 9500 4k and have been having issues with streaming 4k video.

Basic spec:
9500 4k Touch Screen
Intel 10750H
1650 TI

The Problem:
The laptop is now unable to stream 4k from Netflix/Disney Plus. 4k YouTube video very jerky and unwatchable.

I want to see if anyone else has this problem and go over what Dell has done so far. This is our 4th XPS 15 Laptop we bought for work (this is the only 4k model though). Really like them so this isn’t a “slag off Dell” post. Just wanted to write up where I am with it. Sorry for the long post.

When new (bought in late 2021), this laptop played Netflix 4k films fine using the Netflix app. When you go into Netflix and select a film (say 6 Underground), the info shows its Dolby Vision - Atmos. It played the film in full 4k, HDR etc. This can be checked by pressing CTR, SHIFT, ALT, Q when the film is running to pull up the nerd info from Netflix. Here it shows it’s running in 4k etc. Disney Plus app also worked fine in 4k.

Using Edge browser to open Youtube and run a 4k 60 FPS video was also fine. Stats for nerds showed no dropped frames here, great video smooth playback.

A couple of months on I’m not able to play 4k films in the Netflix app, get Netflix Error U7361-1255-8004CD22. Select the film and the info shows its Dolby Vision – Atmos so it should be able to run in 4k but won’t.

YouTube will play the same 4k 60 FPS video but it's jerky and unwatchable, stats for nerds show its dropping frames constantly.

The only thing that’s changed on the laptop is updating the windows updates and the Dell driver updates. As of writing, ALL bios, driver, windows updates are done.

The Intel Graphics Command Centre says the display is NOT HDCP compatible.

I’ve spoken to Dell, they confirmed the machine is HDCP 2.2 complaint. They thought the motherboard was faulty so sent a tech round to replace it. We replaced the mobo and put in the same Hard Drive and booted it up. Netflix was now able to run a 4k film, but it was jerky, out of sync with the sound and basically unwatchable. YouTube 4k test video was just as bad as it was before. The Intel Graphics Command Centre still says the display is not HDCP compatible.

The Dell Support software found a new bios update for the motherboard, so we flash the bios and install it. Reboot the laptop and now Netflix and Disney Plus won’t play the 4k movies. They throw up the same error codes that mean there’s a problem with HDCP (Disney Plus is error code 39 I think)

I decided to do a full Windows restore and wipe the computer and reinstall windows 11. Fresh install with all the relevant updates and the same problems. Same error codes on Netflix and Disney Plus. Same problem on Youtube 4k video playback.

Dell has offered to replace the laptop but as the 9500 is no longer made, they offered the newer 9510. The problem is they don’t have the 4k screen model so was only able to offer the basic entry model. Whilst I appreciate this, I do need the 4k so as of now I’m waiting for that to become available but it's looking like it will be months before a replacement is offered.

I would be happy to keep my current laptop if there was a way to fix it but as of now, we can't seem to do that.

Does anyone else have this issue or do just have a faulty laptop that needs replacing?

Replies (139)

I received a call from Dell a while ago about this and the latest news I was given was there will be a bios update that will solve this problem. It's due to be released in October (2022) so apparently, we are just a few weeks away from this problem being resolved. 

There were a couple of recent posts in this thread that seemed to suggest a solution had been found, but I don't believe this to be correct. As of today  (22nd Sept) there is still no solution to this problem and we are waiting for the Bios update next month. 

3 Silver

I have been back in contact with Dell and asking about the release date for the new Bios. I've been told that Bios version 1.18.0 has fixed the issue but I also believe the person I'm chatting with hasn't got a clue about any of this.  

Is there anyone in this thread that has upgraded their 9500 to Bios version 1.18.0 (released on the 13th of September) that can confirm if they are able to load the Netflix App and stream a 4k film?


Apparently, a user at the start of page 11 of this thread, has downloaded bios version 1.18 for his 9500, and it did not contain a fix. I also have the 9500, but I am waiting for the potential bios update of October, before updating it

3 Silver

I've had a message from Dell today saying that there will be a Bios update, version 1.19.0, released on the 10th of November.  


You are correct. I am on 1.18 and tested Netflix, Disney+ and Prime windows apps.

In all 3, yes, video now works which is a step forwards, but only in HD. None of the apps gave me the choice to watch in any quality above HD.

I checked the settings in each app and they were all on maximum settings.

However, typically my fibre is down so I'm on a tethered 5g at 20MBs (fast.com) so I will test again later when the fibre is back up.

I assume this is a 9500 + Windows 11 issue or are others having the same problem on Windows 10?


Thanks, Michael
This is exactly what my 9500 did. It would now play the films but only in HD. I found the best place to test this all is in the Netflix App.

If you select a film you get all the details up at the top. If I had the settings set to the Intel GPU it would show the movie was in 4k but throw up that error code when you try and play it.

Switch the setting to Nvidia GPU and Netflix would show that same movie as HD. It would now run it at least, but not in 4k. 

I can’t recall about windows 10 / 11. I think bought the laptop with 10 and did the upgrade to 11 but it never really worked in both.

The internet speed is actually a thing. Netflix will only play in full 4k if it has the bandwidth I believe so let me know when you get to test it with a fast connection.

2 Bronze
2 Bronze

It just doesn't work.  I have gbit internet.

Their latest Bios is 1.19 makes no difference.

I am planning to take Dell to small claims court up here asking for the difference in cost between the 4k and 1080p screen.  And damages amounting to $1000+


Hi there, the bios 1.19 version that you mention is for the XPS 17? cause currently for the 15 that I have the latest bios version is still the 1.18 from September.

3 Silver

Hi YiannisMak,
The Bios update that’s due out in one month’s time (10th November) is for the XPS 15 9500. This will replace the current Bios version released on the 13th September. Dell says this will fix the 4k video playback fault.

I would assume there will be an update for the 17-inch laptop as well as it basically has the same hardware in it as the 15-inch model but I’m not 100% sure on that as of this time.

As of now, it seems the only option is to wait another month until this Bios version is released and see if Dell manages to fix this fault.

2 Bronze
2 Bronze

Dell has uploaded a new bios, 1.20 which doesn't even load on my XPS 9700.

What's this about November 11?  It was supposed to be september, then October and now november?  Don 't you think that the mods here don't know what's going on at all  Its' plain and simple lying

Latest Solutions
Top Contributor