XPS

Last reply by 09-27-2022 Unsolved
Start a Discussion
3 Silver
7583

XPS 15 9500 4k Video Playback Problems

I have the Dell XPS 15 9500 4k and have been having issues with streaming 4k video.

Basic spec:
9500 4k Touch Screen
Intel 10750H
16 GB RAM
1650 TI


The Problem:
The laptop is now unable to stream 4k from Netflix/Disney Plus. 4k YouTube video very jerky and unwatchable.

I want to see if anyone else has this problem and go over what Dell has done so far. This is our 4th XPS 15 Laptop we bought for work (this is the only 4k model though). Really like them so this isn’t a “slag off Dell” post. Just wanted to write up where I am with it. Sorry for the long post.

When new (bought in late 2021), this laptop played Netflix 4k films fine using the Netflix app. When you go into Netflix and select a film (say 6 Underground), the info shows its Dolby Vision - Atmos. It played the film in full 4k, HDR etc. This can be checked by pressing CTR, SHIFT, ALT, Q when the film is running to pull up the nerd info from Netflix. Here it shows it’s running in 4k etc. Disney Plus app also worked fine in 4k.

Using Edge browser to open Youtube and run a 4k 60 FPS video was also fine. Stats for nerds showed no dropped frames here, great video smooth playback.

A couple of months on I’m not able to play 4k films in the Netflix app, get Netflix Error U7361-1255-8004CD22. Select the film and the info shows its Dolby Vision – Atmos so it should be able to run in 4k but won’t.

YouTube will play the same 4k 60 FPS video but it's jerky and unwatchable, stats for nerds show its dropping frames constantly.

The only thing that’s changed on the laptop is updating the windows updates and the Dell driver updates. As of writing, ALL bios, driver, windows updates are done.

The Intel Graphics Command Centre says the display is NOT HDCP compatible.

I’ve spoken to Dell, they confirmed the machine is HDCP 2.2 complaint. They thought the motherboard was faulty so sent a tech round to replace it. We replaced the mobo and put in the same Hard Drive and booted it up. Netflix was now able to run a 4k film, but it was jerky, out of sync with the sound and basically unwatchable. YouTube 4k test video was just as bad as it was before. The Intel Graphics Command Centre still says the display is not HDCP compatible.

The Dell Support software found a new bios update for the motherboard, so we flash the bios and install it. Reboot the laptop and now Netflix and Disney Plus won’t play the 4k movies. They throw up the same error codes that mean there’s a problem with HDCP (Disney Plus is error code 39 I think)

I decided to do a full Windows restore and wipe the computer and reinstall windows 11. Fresh install with all the relevant updates and the same problems. Same error codes on Netflix and Disney Plus. Same problem on Youtube 4k video playback.

Dell has offered to replace the laptop but as the 9500 is no longer made, they offered the newer 9510. The problem is they don’t have the 4k screen model so was only able to offer the basic entry model. Whilst I appreciate this, I do need the 4k so as of now I’m waiting for that to become available but it's looking like it will be months before a replacement is offered.

I would be happy to keep my current laptop if there was a way to fix it but as of now, we can't seem to do that.

Does anyone else have this issue or do just have a faulty laptop that needs replacing?

Replies (115)
3 Silver
795

Also have the same problem.

To my recollection, the built-in display always has shown up as non-HDCP compliant according to the Intel graphics driver, but in the beginning there was no issue (only that dolby vision processing cost so much GPU processing that 4K playback with HDR enabled stuttered constantly and was unusable).

I also tried a lot of DDU and different driver versions, but nothing represented a longterm solution. I was too lazy to reinstall the machine and test with Win 10 again (I am also on Win11).

For a while I found that 4K playback was not possible at all with newer than Dell's officially supported iGPU driver, but now I am running 1660 and it works the same as the official one, but without the huge memory leaks.

I have used the Cyberlink UHD Blu Ray Compatibility Tester, because that checks if the entire system is HDCP 2.2 compliant, which is required for Netflix 4K playback and it is (according to Cyberlink, which has been reliably detecting incompatible displays / docks on all my devices so far).

My workaround: if I attach an external display that is HDCP 2.2 compliant and also detected as such by the Intel driver and restart the Netflix app, it works for a while (an entire movie) until it stops again (possibly after standby or hibernate, but nothing deterministic so far). So this is some really weird software bug either in Windows, Intels driver or Netflix. It seems to me that it gets confused by Intel listing only a non-compliant display, even though technically everything is actually encrypted. If the supposedly non-compliant monitor is no longer the only one, then the problem goes away. Even after detaching the external display and restarting Netflix again it keeps on working for a while. But some time later / the next day it will show the same error again and refuse to work again.

 

Seems to me, that Dell needs to get that Intel GPU driver fixed, because that should really see the display as compliant. Whether this would suffice to permanently solve this I do not know.

But my 9500 and my previous XPS 9Q33 have had tons of other driver / software bugs, so Dells software being severely broken and Dell attempting to solve this by ignorantly swapping HW sadly is nothing new to me.

2 Bronze
2 Bronze
725

Was anyone able to resolve the Error code: U7361-1255-8004CD22 on netflix? 

2 Bronze
2 Bronze
707

This problem wasn't resolved, and the screen does get a little jerky when using chrome browser to watch shows.

2 Bronze
2 Bronze
704

I also have the same model as the OP but running a recent clean install of windows 10 and have the same Netflix 4K error and now Disney+ error 39. It did previously work for the past year so it has to be a recent update either the intel driver, Netflix app, or the HEVC extension. Uninstalling HEVC extension at least enables 1080P in Netflix but does not resolve the disney+ error. Amazon prime video seems to be unaffected.

I called the Dell support line <Customer number removed. TOS77> but they just made me do the bios hardware test and since it passed the test they would not help me any further, instead they tried to make me pay for software support. 

1216

Im having same issue. whatsapp support is useless i just want this machine is paid $3200 plus for to do the basics like stream 4k please replace this device with a 9510 or 9520 so i can get what i pay for.... my current specs are

9500 4k Touch Screen
Intel 10750H
32 GB RAM

1TB SSD
1650 TI

2 Bronze
2 Bronze
642

Who did you contact to have it replace the agents are basically just saying oh well it's not HDCP compliant . And I'm like after I spent all this money and it used to be but your updates broke it!!?

3 Silver
640

I'm in final talks with Dell about this. Currently the issue is not resolved but they have asked for another 24 hours. I’ll give a full report once I hear back from them.

617

I can confirm the UHD 4k Touch Screen XPS 9500 is HDCP compliant. They sell it as compliant, I have it in writing from Dell it's compliant and the Tech that was here to swap out my Motherboard called Dell and they confirmed it was complaint over the phone. Don't let a 1st level support tech tell you that it is not. That laptop is HDCP 2.2 Compliant. Full report will follow once I have heard back from Dell tomorrow. 

598

Ok afterwards if you don't mind sending me your resources because this is outrageous.

2 Bronze
2 Bronze
609

I hope there is a resolution to this, I remember Intel graphics command center always reporting the 4K display as being non-HDCP compliant ever since I bought this laptop in 2020.

I asked a friend that has the same model if they can play 4K netflix, but they never tried until after I asked them. They reported to me that it would only play 1080P even though they have a 4K subscription with it set to stream at high quality and have installed the HEVC extension in windows.

It makes me wonder if 4K Netflix only worked before because of a bug in the Netflix app that has been fixed?

I feel like I wasted money on this laptop with the 3-year AD warranty that the level 1 techs won't help me get replaced because the hardware passes those basic tests that can't detect why 4K no longer works.

Latest Solutions
Top Contributor