XPS

Last reply by 09-26-2022 Unsolved
Start a Discussion
3 Silver
7541

XPS 15 9500 4k Video Playback Problems

I have the Dell XPS 15 9500 4k and have been having issues with streaming 4k video.

Basic spec:
9500 4k Touch Screen
Intel 10750H
16 GB RAM
1650 TI


The Problem:
The laptop is now unable to stream 4k from Netflix/Disney Plus. 4k YouTube video very jerky and unwatchable.

I want to see if anyone else has this problem and go over what Dell has done so far. This is our 4th XPS 15 Laptop we bought for work (this is the only 4k model though). Really like them so this isn’t a “slag off Dell” post. Just wanted to write up where I am with it. Sorry for the long post.

When new (bought in late 2021), this laptop played Netflix 4k films fine using the Netflix app. When you go into Netflix and select a film (say 6 Underground), the info shows its Dolby Vision - Atmos. It played the film in full 4k, HDR etc. This can be checked by pressing CTR, SHIFT, ALT, Q when the film is running to pull up the nerd info from Netflix. Here it shows it’s running in 4k etc. Disney Plus app also worked fine in 4k.

Using Edge browser to open Youtube and run a 4k 60 FPS video was also fine. Stats for nerds showed no dropped frames here, great video smooth playback.

A couple of months on I’m not able to play 4k films in the Netflix app, get Netflix Error U7361-1255-8004CD22. Select the film and the info shows its Dolby Vision – Atmos so it should be able to run in 4k but won’t.

YouTube will play the same 4k 60 FPS video but it's jerky and unwatchable, stats for nerds show its dropping frames constantly.

The only thing that’s changed on the laptop is updating the windows updates and the Dell driver updates. As of writing, ALL bios, driver, windows updates are done.

The Intel Graphics Command Centre says the display is NOT HDCP compatible.

I’ve spoken to Dell, they confirmed the machine is HDCP 2.2 complaint. They thought the motherboard was faulty so sent a tech round to replace it. We replaced the mobo and put in the same Hard Drive and booted it up. Netflix was now able to run a 4k film, but it was jerky, out of sync with the sound and basically unwatchable. YouTube 4k test video was just as bad as it was before. The Intel Graphics Command Centre still says the display is not HDCP compatible.

The Dell Support software found a new bios update for the motherboard, so we flash the bios and install it. Reboot the laptop and now Netflix and Disney Plus won’t play the 4k movies. They throw up the same error codes that mean there’s a problem with HDCP (Disney Plus is error code 39 I think)

I decided to do a full Windows restore and wipe the computer and reinstall windows 11. Fresh install with all the relevant updates and the same problems. Same error codes on Netflix and Disney Plus. Same problem on Youtube 4k video playback.

Dell has offered to replace the laptop but as the 9500 is no longer made, they offered the newer 9510. The problem is they don’t have the 4k screen model so was only able to offer the basic entry model. Whilst I appreciate this, I do need the 4k so as of now I’m waiting for that to become available but it's looking like it will be months before a replacement is offered.

I would be happy to keep my current laptop if there was a way to fix it but as of now, we can't seem to do that.

Does anyone else have this issue or do just have a faulty laptop that needs replacing?

Replies (113)
2 Bronze
2 Bronze
544

Absolutely the same issue, except I have a 10885H CPU (Core i9) and 64G RAM. It is super annoying that I can not even watch Netflix on a top-tier laptop.

2 Bronze
2 Bronze
535

My NB model is Inspiron 7500. win 10. firmware/driver update to 2022/6/5.

I found an alternative solution.

use a second screen. (mine is samsung tab s7+).First the projection extends to the second screen. Then open the netflix app.Of course, this is an opportunistic approach.

螢幕擷取畫面 2022-06-05 223052.jpg

3 Silver
510

Thanks, there’s always a workaround and the external screen trick will certainly work. But I do feel that when you buy a top of the range Dell Laptop you should really expect to be able to do what it’s meant to do. It’s kinda like buying a Ferrari and being told you can drive it around but as long as you have a tow truck and a mechanic follow you.  

2 Bronze
2 Bronze
500

edit

2 Bronze
2 Bronze
513

This has something to do with the stupid UWP setting in the task manager that Dell doesn't allow us to turn off.  If you look in the task manager while attempting to play a Dolby Vision video, you will see "Dolby Vision Extensions" with a little green leaf next to it. This means the computer has "suspended the process to improve performance".  The green leaf should turn off when playing Dolby Vision, but for some reason it doesn't and  Dell isn't giving us the option of manually disabling it.  I found a temporary fix by toggling the refresh rate in the display settings.  Turn it to 48 and then back to 60.  This allowed me to play Dolby Vision videos in the Netflix app, but eventually I had to toggle the refresh rate again for it to play again.  When the video plays, look in the task manager and you'll see the little green leaf is no longer next to "Dolby Vision Extensions" . A permanent fix would be giving us the ability to turn off this stupid UWP process setting in the task manager.  It's more trouble than good. 

3 Silver
508

Thanks Joesha, 
When this problem was first identified, I did try changing the refresh rate to see if it made a difference. I've had another good play with it again today but at every setting (48 Hz, 59.93 Hz and 59.99 Hz) Netflix and Disney + Apps still won't play and throw up the same error code. 

2 Bronze
2 Bronze
501

One strange thing I did notice is that I have no issues playing certain animated Dolby Vision videos in Netflix.  I tried playing Arcane in the netflix app and it plays without any issues.  Very strange. 

523

I've just given it a go. Arcane info does show as Dolby Vision and it does play but it plays in 1920x1080 rather than 4k. I can play some Dolby Vision movies it seems but not the ones in 4k. 

2 Bronze
2 Bronze
524

I raised a case to the software team, even told them about this thread. They made me upgrade the video card drivers to the latest versions from intel and nvidia, no change.

They wanted me to waste more time trying things yesterday, I told them I wanted a hardware replacement since it’s the only thing known to work right now. They refunded my money for the call and told me to call the warranty team, give them the software support case number and ask for a hardware replacement. 

That team just made me do the same silly stuff like reinstall the latest bios update. And they wanted to keep me on the phone doing this stuff, no matter how many times I told them it’s a known issue. After about 6 hours in total of wasting my life on the phone with Dell support I told them I give up and don’t want there “help” anymore. 

It’s just ridiculous considering how expensive this laptop was and it can’t even do what basic off the shelf laptops can do without carrying an HDMI adapter and external monitor with it everywhere. What’s the point of a laptop? 

2 Bronze
2 Bronze
513

This will unfortunately be the last Dell I get thanks to this issue.  This used to work just fine and obviously it's something they changed because I don't think it's an issue with other laptop manufacturers.  

Latest Solutions
Top Contributor