Last reply by 04-01-2020 Unsolved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 9560 Fix for the new TPM has "disappeared" issue

Recently I found my XPS 15 halts on startup with a screen saying TPM has "disappeared". I can manually click on continue and get going, but it is an issue when the laptop does an auto Windows update overnight and halts there to burn for the whole night, as the HW system seems to be running at maximum power during that bios screen. 

Checking bios options, the TPM option is nowhere to be found. With some Googling, I found this post with the exact error message that I have: XPS 15 9550 - TPM has "disappeared" Tried all possible solutions on that post and nothing worked. I even got an issue after removing RAMs that XPS 15 does not boot with the edge led blinks yellow 2 times and white 4 times. A post says it's RAM issue so I cleaned them several times, tried only keeping one RAM in and the same issue goes on. I finally tried keeping the battery unplugged and booted with the power adapter connected and that solved the issue.

The solution to fix the TPM disappearing issue is to downgrade the bios from 1.16 to 1.15. The funny thing is, in the 1.16 release notes it says "Fixed the issue where the TPM option disappears from the BIOS setup menu intermittently." and I did not encounter any TPM issue at all before this. Someone from Dell needs to have a look at this 1.16 bios driver update.

@Anonymous, for future upgrades, please make sure you don't break it by fixing it!

Labels (3)
Replies (3)
2 Jasper
2 Jasper

Sorry to hear about this. Actually, 1.16 is a great fix for me - it fixes an issue where there the TPM chip would occasionally go missing from BIOS - usually when resuming from sleep. This was a major PITA for me for years now, as I use bitlocker and there was nothing more terrible to be on on business and have to enter the recovery key in front of clients... But apparently the fix introduces a new problem to others (I don't have it).
2 Bronze
2 Bronze

Same issue upgrading to BIOS 1.18. Come on, DELL!!


BIOS 1.18 update causing the same TPM missing error!

Latest Solutions
Top Contributor