XPS

Last reply by 04-04-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
31911

XPS 15 9560, firmware 1.19.2, Alert! TPM is not detected

Followed all of the support knowledge base and some other guides, but nothing worked. Here is my situation:

1. Device Manager- not showing security devices at all (Including TPM)

2. BIOS (F2) has no option for TPM security

3. Bitlocker- off

4. TPM 2.0 firmware software and driver "TPM query failed"

5. When powering off, unplugged, wait 30 seconds, plug back in, turn on device - problem still shows up

6. When powering off, unplugged, take out battery, drain battery 60+ seconds, plug everything back- same problem

7. Downgrading to 1.15- "ME Firmware downgrade was not allowed", "Firmware update failed"

8. Admin powershell / disable-tpmautoprovisioning - device is not ready for use

9. tpm.msc - compatible TPM cannot be found

 

I read as much as I could, but I could not find a solution. 

@Dellalias

@TeHe 

@Richie1981 

@JD111 

If anyone could, Please help this poor student and Thanks!

 

 

Replies (64)
2 Bronze
2 Bronze
4149

Since the beginning with BIOS version 1.16, they have not fixed this bug.
I think the main thing for Dell is to make money. They are not interested in working with clients.
Just don't recommend buying Dell to anyone. That's all.

2 Bronze
2 Bronze
4171

Yep having the same problem with my XPS 15 9560. Do we know when dell might fix this?

2 Bronze
2 Bronze
4245

I have been having the same issue. I've taken all of the suggested steps and nothing has worked.

2 Bronze
2 Bronze
4266

Same exact issues. Purchased 1 year warranty expired on August 31, 2018. Thanks to the original poster for the excellent detail.

4407

Also having this issue and have completed recommended steps. Commenting to follow this discussion to discover if Dell will actually step up or if they believe in continuing the practice of creating errors like this that force customers to buy new products from them.

2 Bronze
2 Bronze
5291

I have the same issue. Reverting the bios back to 1.15.0 (https://www.dell.com/support/home/en-uk/drivers/driversdetails?driverid=T4GMN) was partially successful. Some components of the BIOS cannot be downgraded. This worked although some Dell process automatically updated the BIOS back to 1.19.2 on the next restart and the problem came back.

2 Bronze
2 Bronze
5331

Same problem here but on top of the TPM Error, I am always stuck on the Dell Loading page and have to go through the loading page..

Tried any "solution" I could find but none of them worked.

2 Bronze
2 Bronze
5377

I have tried exactly same steps and no solution. DELL step up and fix this!

2 Jasper
2 Jasper
5487

Strangely enough, the TPM appeared out of nowhere.

But I stopped using Bitlocker and the TPM..........

All I know was that I was running the a image with Windows 10 1903 at the time, created with the Media Creation tool.

After Windows 10 1909 was released, I restored my XPS with de Dell Stock Image with Windows 10 1909, created with Dell OS Recovery tool. After that, the TPM was detected again. While testing I also set my Bios to Default Settings and Factory settings.

Now I'm running a stock install (created with Media Creation Tool) with Windows 10 2004 and it's still available.

So I really can't give a correct solution about how it was fixed..............

 

2 Bronze
2 Bronze
5677

I have the same problem with my xps 15 9560 bios 1.19.2

Latest Solutions
Top Contributor